Can YOU solve this one? iOS notifications only work on wifi!

I have had the below automation for quite some time, and it has always worked. It recently stopped working. Upon investigation, I found that it works when I am at home on my wifi network, but not on cellular. Does anyone know what would cause that?

          - service: notify.mobile_app_mikes_iphone
            data:
              title: "Activity While Nobody Home"
              message: "The {{ trigger.to_state.attributes.friendly_name }} is now {{ trigger.to_state.state }}."
              data:
                push:
                  category: "last_person_leaves_home"
                  sound:
                    name: default
                    critical: 1
                    volume: 0.4

I’m on Android, so may be different, but is the app’s external URL still in place?

Yes. It has separate internal and external URLs. Both are correct. And the app does work remotely. I’m just not receiving the notifications.

1 Like

Had the same problem, internal notifications and external app access worked. Reinstalled the app and now no local notifications either! But the app works fine otherwise :exploding_head:

After trial and error, I found that it is not simply internal vs external. After a fairly recent HA restart, notifications do seem to work externally. But if has been anything longer than 12 hours or so since a restart, it almost never works. There’s really nothing useful in the logs to help debug. Very frustrating…

There was no prompt to allow notifications after reinstalling and I thought it was allowed since it didn’t ask and was enabled before. Turns out after reinstalling the app I had to go to notification settings in the app and re-authorize notifications. Everything’s been fine since.

So in my case, it looks like reinstalling fixed the initial issue of no external notifications. Maybe something to try.

1 Like