Canary camera sensors have stopped showing

I have a Canary camera component in my setup which has worked perfectly for months. But the sensors (air quality, temperature and humidity) have all disappeared.

The camera component still works, showing as an entity in the developer tools and I can access the camera image via my Lovelace UI.

However, the sensors don’t show at all in the developer tools. They don’t even show as an unknown state. I’ve checked my log in the UI>Info panel and I’m not seeing any errors. And I’ve checked the latest HA component docs and can’t see that anything has changed, it implies if the camera component is configured and canary is configured in configuration.yaml then the sensors will be auto added.

Can someone help me trouble shoot this issue?

1 Like

I also have this issue. Noticed it the other day. Just upgraded to latest Hassio to see if it helped but still the same. Exactly as described by Sentur. I’m looking into it and will update

1 Like

Glad to hear it’s not just me. I’ve tried updating each time with the incremental updates for 0.91.* and still seeing the same issue with each new update.

I also tried rolling back to 0.90.* but the lack of canary sensor was persent.

1 Like

Same issue here, I think Canary might have changed their API.

Slightly off-topic but you might be interested if you use custom-ui:

I was on 0.84.6 and following a restart the states UI stopped working. I thought there was an issue with some components but the debug log didn’t help. Eventually I decided to go for an update (I was postponing as I didn’t have time to handle the breaking changes), to see if a component update would fix the issue.

Again, it didn’t work and after almost a day of debugging I found out that custom-ui breaks (and prevents the UI from loading) if you customise unavailable entities. So when the Canary sensors disappeared, custom-ui failed at the first reboot.

1 Like

Still seeing the same issue in 0.92.* :slightly_frowning_face:

1 Like

I am experiencing the same problem but my cameras showed up once but not anymore. I am also getting this error.

Invalid config for [canary]: expected a dictionary for dictionary value @ data[‘canary’]. Got ‘username:[email protected] password:XXXXX’. (See ?, line ?). Please check the docs at https://home-assistant.io/components/canary/

1 Like

I raised an issue in the HA github. Hopefully this will prompt the component owner to develop and deploy a fix.

1 Like

Still broken in HomeAssistant 0.93.

1 Like

Still broken in HomeAssistant 0.95.4

1 Like