Candeo Zigbee dimmer finally working with ZHA

Thought I’d share my experience of this as it might save someone else sometime. I’ve been trying to get a Candeo Zigbee dimmer (the one with single rotary button might be specific to the UK market) working. Initially found it paired with ZHA but wasn’t reporting its state correctly - even when on would report as off. It was possible to control but without looking at the light impossible to know what state it was in.

Following some suggestions I switched to Z2M where it actually worked fine but for various reasons had to switch back to ZHA. I’m using a the latest HA (as of May23) with a SkyConnect USB into a Pi. Updated the firmware on the SkyConnect so had basically run out of options. Luckily noticed that Candeo indicate this is a known issue with firmware on some of these. Details here: Support – C202 – Candeo

I contacted them by chat and within a couple of hours was sent a new firmware to flash via OTA update - was a bit of a pain to actually get this to take (even though they provided good instructions).

So if your device is an older one - you can check as follows (this is from their instructions):
Please check firmware date of your Candeo device -
Device Info > 3 dot menu > Manage Zigbee Device >
Cluster - Basic
Attributes - date_code

If the date code of your device is 20220531, please proceed with this firmware upgrade.

Then get in contact with them for the latest firmware. Having updated, restarted and reconnected a few times it’s working perfectly with ZHA.

Edit: should add they also gave me the option of sending the dimmer to them, so they could update the firmware … but where’s the fun in that!


Hi thanks for posting this I have been experiencing the exact same issue and wanted to resolve before buying any more units. Can you make the new firmware available for download possibly?

Yep no problem - here’s a link to the instructions from Candeo and Firmware, I’ve zipped them: Dropbox - - Simplify your life

I’ll leave that as a public link.
Note I followed the Candeo instructions a few times last night and didn’t think it had worked but some combination of restarting HA and repairing the dimmer (which I thought had hung) worked this morning.

Actually the one new thing I did this morning was use the Gui to force an update of the firmware - might have been that which worked. i.e. go to Settings > Devices > Zigbee and find the dimmer > the click the three dots and select manage device > on the clusters tag select Ota (endpoint …) > commands and select image_notify > payload_type = QueryJitter > set the slider to 100 and click issue zigbee command (should give a green tick)


FYI, I just ran this and it worked first time for me. :slight_smile: I didn’t restart HA, or make any changes other than those in the document.

I have a second Candeo dimmer with an older firmware, 20211101. It is working ok as is, so probably no real need to update it except for it making my OCD itch to have two devices on different firmware revisions. Candeo’s documentation says that the OTA update is only for devices with 20220531 firmware and warn not to use it for anything else. But I’m so tempted to try…

1 Like

Thanks so much for posting this goldenape! I’ve got a bunch of these dimmers but the last two had this exact issue and I spent ages trying to debug what was going on and why they weren’t reporting state correctly. Flashed the new firmware per the instructions and now they’re both working perfectly :slight_smile:

A pleasure!

This is awesome as I was just going to return this thing. I’m following the instructions and I put the code they said to in my configuration.yaml and restarted. However, it did not create the config/zigbee_ota folder nor does the ZHA Toolkit come up in developer tools. So it seems that somehow the code is not being picked up in the configuration.yaml? If anyone has any advice I would appreciate it.

Instructions published on the Candeo website -

You need to create the config/zigbee_ota folder yourself.
And install ZHA Toolkit from HACS.

Thank you I totally missed the part about installing the Tooklit from HACS. I did create the folder previously. So I got all that done, but still doesn’t seem to be working. Wondering if you might have any additional feedback. Following the instructions I added this to my configuration.yaml file:


        otau_directory: /config/zigpy_ota
    default: info
      homeassistant.components.zha: debug
      zigpy: debug

I put the zha and logger indented and not indented under ZHA toolkit as I wasn’t sure if that would make a difference.

This is what I have in developer tools under services:

service: zha_toolkit.ota_notify
  ieee: light.living_room_dimmer_light

I click call service and get a green checkmark, but no activity in the home-assistant.log at all.

Any advice anyone can provide is appreciated.

Did you copy the firmware file to the right folder?

And did you restart HA in between adding the code to configuration.yaml and running the notify service?

Yes the file is in the right folder and I rebooted in between. At this point I’m thinking just to return this thing or get them to send me an updated one. Thanks for your help.
Screenshot 2023-06-28 013336

What is the date code on the device now?

I suggest contacting Candeo support.

Wow, it changed to the code 20230401 and is working properly now! I didn’t even think to check since nothing happened with the logs. Thanks again!

1 Like

I contacted support before finding this thread. That’s what the product support page tells you to do now, no instructions. Before they could reply, I found your posts, tried it and it worked.

Support did get back to me a few hours later, asking for my date code, with no further instruction. I told them what I’d done. Their reply was slightly concerning. Emphasis mine.

Ok – that firmware file is not a good solution for you. Unfortunately it will have created another problem, and also means that your device can no longer be updated.

We removed this firmware from our site some time ago, while we are working on a suitable new firmware.

We will be publishing the new firmware in the coming days.

Personally, I’m happy to have a dimmer that works now. These have been half-broken for a while and I’m not sure what future patches could fix, but I’m not wild about their communication.

Either which way, I thought other people who are considering this might like the warning ahead of time. You might want to hold off but I’ve no idea what “coming days” means in Candeo time.

Did you see this? Possibly updated today or yesterday?

I’ve engaged with Candeo support team once before, and found them very helpful and professional.
My advice would be to always get firmware files from the supplier website - and probably not the community.

I’m trying to update Firmware OTA using ZHA toolkit and having problems. Following Candeo’s instructions, when I do step 6 & 7:

  1. Go to Developer Tools > Services, and choose “ZHA Toolkit: ota_notify” In the ieee field choose the Entity of your Candeo dimmer light.

  2. Select “Call Service”

Then I get this error message:

This error originated from a custom integration.

Logger: custom_components.zha_toolkit.ota
Source: custom_components/zha_toolkit/
Integration: :toolbox: ZHA Toolkit (documentation, issues)
First occurred: 9:10:57 AM (1 occurrences)
Last logged: 9:10:57 AM


Has anyone else encountered this problem, and found a solution?



Turns out problem here was my own stupidity! Folder name for the firmware file had a typo.

Can anyone in the UK suggest a retractive switch that will work with these candeo dimmers in a 2 way setup please? Perhaps there are no special requirements, and any ‘retractive’ switch will work, but a known working model would be helpful.

Thanks for sharing this - I’ve had one of these dimmers for over 6 months and had all but given up on getting the status reporting working properly. Stumbled across this thread, and installed the 20230824 version. Didn’t get any feedback in the logs, but the dimmer dropped off my network and after re-pairing it I’ve confirmed that the new firmware is loaded and it’s now working properly

In case it’s helpful to anyone, I had the incorrect state issue with the standalone neutral-optional dimmer module, and running through the ZHA-Tools-powered OTA firmware upgrade process did the trick for me.