Cannot access DUCKDNS from within LAN (SOLVED)

Hello all, I am getting an “Unable to Connect to Home Assistant” error screen when using DuckDNS from within LAN.

My set-up

  • Router: OPNSense. GUI is using a non-standard port (not 443)
  • DNS: Adguard Home + Unbound as plugins within OPNSense.
  • HomeAssistant OS is running NGINX Proxy Manager integration (thanks Frenck!).
  • Port forwarding: I am forwarding 80 and 443 to hass_ip. And, in Unbound DNS Overrides, I have my duckdns domain with value of hass_ip (type A). I think this is how to set up a split DNS, right?

If I access hass_ip:8123 from LAN it works.
If I access duckdns from WAN it works.

But, if I access duckdns from LAN it does not work. Interestingly, the URL changes to and I get a home assistant icon so it looks like it is making some sort of contact with home assistant…but text under it states: Unable to connect to Home Asssistant.

Additionally, accessing other Proxys set up on NGINGX work from WAN but from LAN thye get me ERR_CONNECTION_TIMED_OUT.

Turning on NAT reflection makes no difference.

Any ideas what is messed up??

SOLVED. The problem was that I had the split DNS in unbound when it should be in Adguard. Because it is going Adguard → Unbound, I needed to use DNS rewrites in Adguard under filtering. Added and * entries that redirect to hass_ip (aka and more importantly nginx_ip) with ports 80/443 forwarded to the same hass_ip. Everything works now.