Cannot access HA from Android HA app

Hi All
Pulling my hair out here. I cannot access HA server from my Smsung Android mobile. I have the HA app installed.
Some background - I have been using the HA app on android and IOS for 12 months or so with no issues. Also setup the Cloudflare link so I could access it remotly all was working ok.

I decided to remove the Cloudflare add-on and try a VPN solution Tailscale.

So I uninstalled the Cloudflare add-on and prior to installing Tailscale I though I would just check I can still access HA from mobile devices. From my Androtd I cannot access HA and get an error message ERR_SSL_PROTOCOL_ERROR.

Also tried accessing via a browser and the same error.

I can ping the HA server from my Android mobile.

HAOS install on PC and connected by a network cable to the router.

My feeling is there is a certification issue some where but im dammed if I can find it.

Any help plz would be appreciated

Wild guess: by removing the addon, your HA reverted to using http://