Cannot access HA on PROXMOX Solved

I have a running HA om ESXi since years with a lot intergration, MQTT devices etc.
Now I am moving to PROXMOX with all may servers, the last on is HA, I tried to move it like the other servers but failed. So I did a full backup an installed a new HA with the script and select import full backup. That runs over the night and seamed to finish. he new HA got a new IP address, port 8123 is open, but the browser ansers “target sents no data”, I rebooted the new HA, console come up as normal, but no browser access.

Need urgend help, it’s the laster server to move to be able to switch of the ESXi
Thanks for any hel or hint. The old HA on ESXi had the newest version

You have used a script to create HA. Try my guide which might provide a working solution. Everything is done manually and you are in full control of the process.

1 Like

Very nice guide, you did an excellent work, but it does not solve my problem. It begins after the installation. As I have a running complex configured HA on VMware ESXI that I want to move to PROXMOX and a direct mirgration dis not work as on my other Linux servers I did a full backup and tried to import it to the on on PROXMOX. The Import ran all over the night, website did not react any more. So I rebooted HA, it came up normaly, but browser cannot connect any more.
What went wrog with the import?,I checked port 8123 it is open

in the console try the normal troubleshooting commands

ha core logs
ha core rebuild
ha su repair
1 Like

Which script? :wink: There are tons out there…

What did you do exactly to restore the backup? Please list your exact steps, like

  • Installed Proxmox with script XY, no errors
  • Installed HA with script XY, 1 error => the error

and so on.

used this guide first Installing Home Assistant OS using Proxmox 8

**3.1)** To install the Home Assistant OS virtual machine, copy and run the following command in the Proxmox Shell.

bash -c “$(wget -qLO -”

Then tried []( version

Both installation looks fine, after the 20 minutest configuration
the I check configure from full backup, did upload the backup.tar

should be finisch in 45 Minutes, waiter first time all night, second time over an hour. 

Import did not finish. but the ha console came up. The shown address is up, port 8123 is up, But browser chrome say no  data. core log shows a lot of error see attached screen shot
did `ha core logs
ha core rebuild
ha su repair`

then reboot, same problem with the browser
I like to import my old config as a manual rebuild would be a lot of time.
Or someone can give me a hint to migrate the ESXi version build on the ova image in 2019
migrating this does not boot.
otherwise what can I do to export the current config, other than makeing a full backup manualy.

thank for help

my server is a prfession Fujitsu server with dual quadcorde Xenon and 40 GB of RAM
![Bildschirmfoto 2024-04-18 um 17.03.14|690x411](upload://Ac5hUzNMNUQnE3Lrp8SGWOIvQhR.jpeg)

For now, stick with one script or tutorial, trying other things in between will not get us faster to a solution. :slight_smile:

Your post is a little messed up with the formatting, so I can’t see your screenshot, sorry.

Anyway, the script to install HA ends with “✓ Completed Successfully!”? Is this installation running and can you access this new installation via your browser?

If so, what were the next steps you took?

And another question upfront, how big is the backup you’re trying to restore? The bigger, the longer it takes, but a whole night seems to be too long. :slight_smile:

Yes could accees the startup screen of the new installation the selected configure from from full backup, uploaded the the tar file, from a fullback (version on ESXi is the the same as the new installation.
But the import never ends, browser gets no data, IP address is valid port is open
Thanks for your help

So, in the proxmox vm console, what does

ha core logs

return ?

1 Like

I did see screenshot I posted above

lot of error I do not understand

That post is so mangled up, no one can see the screenshot.

1 Like

if it is you that cross-posted

  • Did you pass-through your Zigbee stick to the HA VM ?
  • There is a problem with your certificate
  • There is a problem with your fritzbox integration
1 Like

have no zigbee stick, but the lidl gateway
certificate problem, which can you clear what you mean integration, not essential for me I can revome if thats the problem
Thanks for help

1 Like

to issue 1 zigbee stick, the gateway has a lan connection, never ever had or used a serial connection, the old HA was a VM on ESXi, the new one is a VM on PROXMOX,
so what should that serial connection error

to issue 2 certificate error, never did anything with certificates did not need it, the new ha is the exact same version than the old, why is there a different behavier

to issue 3 connection why should there be a problem now

As I see it´s a docker implementation. In my experiance two instances of the same software version do not behave different, especially docker implemtations as they are indepentent from the rest. So if my backup was correct, I assume the behavior of the docker instance running on the ESX should not differ from that running on PROXMOX.
So may something got wrong with backup, but I cant what you can do wrong in the gui, or something got wrong importing the config, but the you can only upload and start.

Sorry, that I insist here, but I am an IT professionell and had some docker instances running on SUSE Linux and have a quit good knowlege on Linux, but I can not understand the diffent behavier here. Especially with docker. Never had different behavier beetween two docker instances running the same software with the same config.

In any case I apreciate your help, thank you.

The lidl gateway uses a ser2net connection, aka serial over ethernet. Is your ESX instance still running ? There can only be one connection active.

One thing you still can try :

  • Start your ESXi HA instance again
  • Disable (not delete) all your integrations
  • Make a backup
  • Stop your ESXi HA instance
  • Restore the backup on Proxmox
  • Enable your integrations one by one.
1 Like

Thank you very much for your help. Finally I got after delete all the fritzbox integrations, making a new backup and restore on the PROXMOX machine.
What me still took some time to figure out that the backup does not overwrite the DHCP address with the old fixed address. After changing this from the GUI everything is fine again. Is a pity that the is no (at least I did’nt find any) information about the restore process, what it does or at least giving a finish sign.

1 Like