Cannot Access after Duck DNS configuration

Tried to configure Dusck DNS, Here i was in the process.
Set up Duckdns Account
Copied token and configured Duckdns addon
Copied yaml file then started duckdns
checked configuration file and was valid so restarted.
Port forwarded in router to
after restart cannot access on internal address OR on external address.
Pinged rapsberry pi and it responded so it is alive.

PLease any help you can provide. is running on a Raspberry Pi 4.



You have to use https to access Home Assistant now not http.

ok i tried with the https:/ as well and it did not work.
Thank you for the help.

Did you include the port number?

This if you forwarded 8123 to 8123:


1 Like

just tried that and still nothing

Are you trying from within or from outside your local network?

If inside try


And set your browser to ignore the security warning (the SSL certificate is for the domain not the ip_address).

Ok that worked setting the browser to ignore the security warning i am back into it now, but do i need to fix something in duckdns?

Maybe. There are a number of issues that could prevent you accessing via the duckdns domain.

Try disconnecting a mobile device from your wifi and accessing the duckdns domain via the cellular network.

If that does work then the issue is that your router does not support hairpinning. You will have to use the IP address internally and the duckdns domain externally.

If it does not work then it could be a number of things.

  • You haven’t forwarded the port correctly
  • Your ISP uses CGNAT
  • Other…

ok I will keep researching, but thank you very much for getting me back into