Cannot access port 8123 on raspberry pi

Tags: #<Tag:0x00007f7394aca0f8>

Hi everybody.
I installed HomeAssistant on my raspberry pi 4 using the official tutorial https://www.home-assistant.io/docs/installation/raspberry-pi/.
Unfortunately, this installation is non-supervised which seems very limited to me.
I found a great tutorial (Installing Home Assistant Supervised on Raspberry Pi OS) to install a supervised version using Docker. However, I only did the Docker 101 tutorial so I’m very basic.
Unfortunately, silly me didn’t remove the non-supervised, non-dockered installation (I don’t even know how should I)
I did a sudo systemctl stop [email protected], but then localhost::8123 throws an ERR_CONNECTION_REFUSED server error. If I start the service again, localhost::8123 points to the unsupervised version again.

Here are some more info:

[email protected]:~ $ sudo docker ps
CONTAINER ID        IMAGE                                           COMMAND                  CREATED             STATUS              PORTS                  NAMES
bdbf5cb6eeb3        homeassistant/armv7-hassio-multicast:3          "/init"                  2 days ago          Up 2 days                                  hassio_multicast
98fca40d03c0        homeassistant/armv7-hassio-observer:2020.10.1   "/init"                  2 days ago          Up 2 days           0.0.0.0:4357->80/tcp   hassio_observer
b028749522e6        homeassistant/armv7-hassio-cli:2020.10.1        "/init /bin/bash -c …"   2 days ago          Up 2 days                                  hassio_cli
8e57ead0f320        homeassistant/armv7-hassio-audio:17             "/init"                  2 days ago          Up 2 days                                  hassio_audio
55ba04b8c8e6        homeassistant/armv7-hassio-dns:2020.11.0        "/init"                  2 days ago          Up 2 days                                  hassio_dns
013c0d373952        homeassistant/armv7-hassio-supervisor           "/init"                  2 days ago          Up 2 days                                  hassio_supervisor

localhost::4357 is accessible though, and it says “Home Assistant observer - Supervisor:Connected”.
I can also run sudo ha in my SSH console with no problem.

Any idea how could I debug this and have the docker, supervised version on port 8123?

An easy option is just to format your SD/SSD and start fresh using the guide. Start to finish takes about 30mins on a Pi4.

There is no need to use any command line.

Just use an raspberry image for the sd/ssd:


(which is supervised)
burn the image on SD/SSD using balenaEtcher insert it in the raspberry;
boot it up and finish installation on http://hassio.local:8123

It’s also a locked down restricted O/S while many people prefer a real Linux distro…

Tried uninstalling the original version with the following command?

pip3 uninstall homeassistant

totally agree…but i guess there are many more people that don’t have a clue :thinking:

1 Like

Thank you all for your answers.
I have other stuff on my raspberry pi like pihole, shinyserver, and other stuffs so I don’t want to restart from scratch. I also don’t want to install HassOS which I think would dedicate my raspberry to only one task, which seems very overkill to me.
I’m ready to learn anything that would help but I don’t know what since I cannot diagnose the problem.
@ianm unfortunately, the pip3 uninstall didn’t work