Cannot access raspberry via ssh after latest update

I used to be able to log into my raspberry via ssh but I ran the latest update and how i get connection refused.

ssh version 9.1.3
hassio 6.1
supervisor 2021-06.08

The raspberry loads up just fine. But I get connection refused when i try to ssh it. All i did was update my hassio install a couple of nights ago. I can ping the pi just fine, here is its fully loaded screen:

I can log into the webui via home assistant’s open ssh addon. But I used to be able to do it from my mac’s terminal.

What couldve changed from a core update that made it unreachable now from a remote terminal?

from your mac’s terminal use the -vvv option for ssh.

Thanks…i got this:

Screen Shot 2021-07-24 at 6.57.54 PM

Is the SSH addon running?

Also check the supervisor logs.

I didn’t think you could use root as username in either of the ssh addons.

no, thats ssh from a mac terminal. The ssh addon (open ssh) works fine from home assistant interface. Its the remote mac terminal ssh which stopped working. Its the one i use the most.

You can if you set up pre-shared keys.

1 Like

What do you mean, pre-shared keys? I had it working fine before this update. Do you mean in the latest version ssh from a remote terminal is no longer available as it was before? Was it like a security feature? How do I set up these pre shared keys?

I presume you have checked that your hass machine does still have the IP address

yes, you can even see on the home assistant startup screen the IP is shown as well.

Im also currently logged into home assistant and doing stuff to it, and i accessed it via that ip.

I assume OS X has nmap. See if it sees port 22 open?

You could never access the root user without using pre-shared keys.

You must have been using another user.

no, i was using root. i remember because i have 2 rpis and one has raspbian and it uses pi whereas this one has root and i always had to check when looking through the terminal’s history (up/down arrows) to make sure which one I was logging into, and I remember I never relied on the IP because i could never remember which IP was which but I instead used the user in the ssh command to know which one was hassio because it used root.

I scanned p22 (at least i think i did using this command) and this is what I got:
Screen Shot 2021-07-25 at 5.52.00 AM

so port seems to be closed. But I swear, I was using ssh with root on this same raspberry pi from my mac remote terminal a few days ago before the update. Its how i always access my rpi, so im sure of it. Whatever changed, happened after the latest core update.

This has always been the only way to log in as root:

ok well then thats weird because i guess i have been doing something impossible for the past 5 years. I have been logging into my raspberry pi, over my network, from my mac terminal using ssh [email protected] and then entering my password when prompted.

Ok before i continue, let me clear something up in my mind. The openssh “addon” inside the gui of home assistant is one way to ssh into your rpi, right? But you have to log into the ha gui in order to access it:

But for years since ive had my rpi2 with hassio installed and working perfectly, ive used ssh via my mac terminal on the same network like this:

Screen Shot 2021-07-25 at 12.41.53 PM

and like i said, it worked every time with root user. I had never used the openssh addon terminal until yesterday. Its great but i worry about if my HA GUI stops working/loading for some reason, which is common when installing new addons and stuff. This is why ive always considered it important to have an ssh access from terminal and its why Im trying to make it work now.

I installed my HA a long time ago, about 5+ years, and I dont remember but im pretty sure i had to go into some menu (although i think this was on raspbian) or do some mod in boot files (this was probably on hassio) in order to activate the ssh. Ever since then I never had to change anything regardless of updates.

Since I have been unable to ssh back into my rpi after its latest upgrade last week, which im guessing has something to do with it and even though ive been told in this thread i would need to use shared keys in order to make it work which looks messy, id like to understand if the openssh addon can affect my remote ssh access? Because I had never messed with the open ssh addon, i dont know if this was disabled in the past, but I noticed this:

where it says that port 22 is disabled. I want to enable it but again, im worried that if i cant get the ui back up and running, i wouldnt be able to access my pi like before, via ssh remote terminal. So I want to double check, might this be the reason i cant remote access ssh?

The two things you have to do are in the addon docs: addons/ at 4474316ebbb9ed58b29ca4f57ee6e5404f5f52bc · home-assistant/addons · GitHub

yes i read that, im wondering if the way to enable it is to change the “disabled” field value to:

a. “Enabled”


b. “22”
Screen Shot 2021-07-25 at 7.13.07 PM

b. As it says in the documents.