Cannot add any views to HA


I installed new HA and added a couple of switches. I am trying to setup Views and for some reason it does not show me anything that I am trying to see. Can someone help?


# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:

# Example configuration.yaml entry

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
sensor: !include sensor.yaml


  name: Home
  view: true
  - group.family_room_group

  name: FR
  view: true
  - group.family_room_group
  name: FR
  - switch.family_room_lamp

I have this:

The view option for groups doesn’t apply to Lovelace, which is the current default UI (and has been since version 0.86). You can take control of Lovelace and manually create views in the UI by going to Overview, clicking the three dots in the upper right, and clicking “Take control of Lovelace” (or something like that, it’s been a long time since I did that). Then click the dots again and click Configure UI and add whatever views and cards you want.

I have another HA running with version 0.103.5 and I use groups and views.

Does it mean that with all new installations I will not be able to do it anymore?

Not unless you go to Developer Tools > Info and click “Set states as the default page on this device.” Should probably move to Lovelace though since States has been deprecated for a long time and might go away at some point.

Thank you. I was thinking about moving to lovelace, I guess I have to do it sooner than later.

One question, why new installation has this in configuration.yaml file if groups and views go away? Any ideas?

group: !include groups.yaml

Groups and views aren’t going away. You just can’t use the view option in groups with Lovelace.

Do you mean that I cannot use views, but I will be able to use groups with lovelace?

There are still views in Lovelace. You just don’t define them in groups like in the States UI.

Thank you for your help, I know that I can create view with lovelace, I tried lovelace UI on one of my test HA installation. I just tried to understand why the groups.yaml file is still there during new installation.

Because you can still create groups to use in automations and other things.

Got it, thank you very much!!