Cannot add, the token is correct


I have been trying to add the electricitymaps to the Energy Panel but this operation fails with “unexpected error”. However, I know the token is correct because I get a reply when I try to query the service in the browser:

{“_disclaimer”:“This data is the exclusive property of Electricity Maps and/or related parties. If you’re in doubt about your rights to use this data, please contact [email protected]”,“status”:“ok”,“countryCode”:“PT”,“data”:{“datetime”:“2024-04-08T17:00:00.000Z”,“carbonIntensity”:72,“fossilFuelPercentage”:5.93},“units”:{“carbonIntensity”:“gCO2eq/kWh”}}

Could anybody please let me know how this may be fixed in this configuration?:

  • Core 2024.4.2
  • Supervisor 2024.04.0
  • Operating System 12.1
  • Frontend 20240404.1

Thank you very much!
Best Regards,

@andreyotw did you find a solution to this? I had a working electricity maps/co2signal, but it just went to “unknown” state few days ago, and I tried removing and re-adding it and now I’m stuck at the same stage you are. My API key is also definitely correct.

Edit: Working now after upgrading core to 2024.4.3

Hi! Still cannot add the maps … How did you solve it, just an upgrade of the core? Thanks!

I’m having the same issue with 2024.4.3, so that’s not fixed it for me.