Cannot add Unify Integration

Not sure if this is the right place to ask this, please feel free to move it where it belongs.

I am trying to add the Unify integration(not the controller sw). I am being prompted to enter the host name username and password and to check a box to use the proper SSL cert.
Everything is being filled but it spins for few moments then gives me “service not available” no matter what I try.
I have created a new local user for this and I’m sure the credentials are right. The docs under the Unify integration on are very sparse and the rest of the threads here only talk about inputting it manually in the yaml, however if I do that when checking it I get another error to remove it as it has been deprecated.

Does anyone have some docs where I can read and set this up properly. Or is it still supported? I know Ubiquity are not famous for sharing things and it may be broken on their end.
Do I need to run separately the controller on docker? I have a standalone controller.

Thank you

“Unifi”. :face_with_monocle:

Works fine for me with a remote controller (i.e. not even in the same building) that is running behind an nginx reverse proxy. My controller is running two sites and the integration prompted me to choose one of them. I set it up via the UI.

What is your controller running on, and where? Cloud Key on the same LAN? Are you actually using a proper SSL cert (for example, I am as the proxy is using a Lets Encrypt SSL cert)?

My setup is very crude and I am trying to build few home automations. As I recently bought the new UDM Pro I thought would be a good idea to see how does it look like in the hass io dashboard
I am not even yet there :slight_smile: where I expose everything to the outside world. Was simply trying locally within the local LAN to test it out.
My hass is running on a container on a Synology box

Thank you

I switched to hass on a VM from Docker, re-did everything and still having no luck adding my controller
I created a local admin user. Is there anything extra I should be enabling on the UDM?
It runs on the with the user I created and the password. Entered all that, it spins for few seconds then comes back with the error from the attached screenshot.
What am I doing wrong?

I stumbled across a Youtube video and I found out the port is actually 443 and not 8443.
It worked.

Hi…i have same problem with no service.
But my controller works on 8443 and it is a docker container on my synology.
Can you share the link to the youtube link that worked for you?

Sorry I cannot remember
It was something really obscure and buried into some other comment.
Not really sure it would be of any help.
It was literally just a small quote about someone using the 443 port and nothing else.

I’m sorry I cannot be more helpful

No problem thanks a lot

Having similar setup and the same issue as you.
Had a similar issue, but it went away.
My controller version is 5.12.66.
Always have host inserted as only IP: 192.168.1.xx
I found it can be also connected with mongo db, try restarting controller and mongodb containers.

I find the problem, because i have synology container unifi and the hassio installed on synology virtualmachine i have must enable NAT on my Firewall to get it working. Other Things on same subnet dosent need this,only this way it have worked for me. If anyone have same problems to get it working.

1 Like