Cannot Adopt ESP32 because failed to store wifi credentials

Hello there,
I have just bought two ESP32 developer boards and managed to install the ready made project from esp32 homepage:
Ready-Made Projects — ESPHome

I want to create a bluetooth proxy for HA. After installing proper Windows driver I was able to install the bluetooth proxy project.

After that I went to HA and installed the ESPHome Addon → restart of HA ofc :wink:

shortly after the newly created BTProxy popped up and I configured it in HA integrations.
So far everything went smooth.
However I went to the ESPHome Addon from my sidebar an clicked on “adopt” .

After the I end up getting the error “Failed to store Wi-Fi credentials”. PW and Wifi Name is for sure correct. I have already entered it in the beginning when I flashed the Bluetooth Proxy project from the website.

I removed ESPHome addon and restartet HA again. After that I did a fresh installation of the Addon. Same problem.

I have a folder:

howerver it is empty.

What do you think?
Best djm193

I fixed the problem. I was presented with an update for ESPHome. After installing the update I have tried the adoption process anew. After that it worked like it should. No clue why

What do you mean by “… presented with an update for ESPHome…” ??
How was that “presented” and what did you do to update?
What version are you on now?

in the sidebar of your hass interface there is ESP section. If you click on that you will be presented with all of your ESP devices. In this same section you will see a button “Update all” if there are updates for your devices. alternatively you can just update device by device with no need to update all devices.

Well, I have no pending updates for any of my devices.
And the newly “discovered” device which is causing this problem cannot be updated until it has been successfully Adopted. It is when I attempt to Adopt it that it fails with the error.

So this is a bit like the chicken and the egg. There’s nothing to update until it is adopted, and it fails to Adopt.
So what did you update in order to solve this problem?
And what ESPHome version are you on now?

ok then… Try to get new firmware version on your device with the esp32 website. this could help. or you just wait until you will be presented by a new ESPhome update in hass and THEN try to re-add your ESP devices again.

I did flash the latest FW update from the ESP32 Website, and my ESPHome is also updated to the latest version.
I do not think this is an update issue at all.
Many others have reported similar problems, and they solved it by manually crating a missing folder under /config.
However, that solution is not possible unless you run HA-OS and have ESPHome installed as an Add-On.
I have ESPHome installed in a docker container on a linux server.