Cannot assign to read only property '0' of object '[object Array]'

Hi guys,

Having this really strange error in several of my cards after updating to latest release !

Thing is, right after I restart my HA and refresh once all these cards with several graphics seem to display properly but once I refresh again they all return the same error .

Once I restart again I can see the graphics once and then after refreshing the error returns .

Anyone has a clue what might be wrong here ?

Thanks !

Are they custom cards, maybe installed via HACS?
If so have a look at the install instruction for each card.
I experienced the same issue and the latest version of HACS requires the URL for the custom cards to start with /hacsfiles/ instead of the previous /community_plugin/

1 Like

@lolouk44 yes it’s a custom card and I tried installing it via HACS in the meantime (was installed manually before) but it didn’t fix the issue .

I am using the url as specified by the card instructions .

I’m pretty sure I have other custom cards all using the same urls as before with /community_plugin in them , how exactly are you saying I need to change this ?

There is no folder named /hacsfiles/ anywhere , are you saying I need to switch from /community_plugins to /hacsfiles ?

yes, in your ui-lovelace.yaml file you need to replace community_plugins with hacsfiles

Well I’m still using HACS 0.16.1 and was working fine til I updated to 0.106 yesterday, will update to latest version and give that a try thanks !

Don’t think it will work though because I have also tried to install the custom card manually in community_plugins and it didn’t do any good :\

there was a chance in the way HA handles custom-cards in 0.106 so yes try and update HACS first

1 Like

Please also note that besides changing the /local/community to /hacsfiles (as it was mentioned earlier), the js file for the Mini Graph Card has been renamed to mini-graph-card-bundle.js (earlier it was mini-graph-card.js).

1 Like

i have the same problem with

Changed to url: /hacsfiles/atomic_calendar/atomic_calendar.js
Problem remains

1 Like

There’s a new version of the mini-graph-card that has been updated to work with 0.106

Already updated but sadly it still is producing some issues !

I need to Ctrl + F5 to get the cards to display, otherwise they still show all those errors . A normal refresh doesn’t work .

Probably some caching issue

Can you try Ctrl + F5 ?

In my case I need to force refreshing this way to get the cards to display but once I navigate to other menus the problem comes back .

Might be some caching issue testing this now

I can confirm that updating HACS to latest version along with the plugin for the mini graph card and clearing the cache fixed the issue !

Thanks for the input guys

1 Like

Please make sure you upgraded HACS to latest version then try to reinstall the Atomic Calendar card.

its working

still problem with Dual Gauge ; type js (addon page) or type module (readme page)?

1 Like

I have the same issue on the dual gauge card…

Solved by editing the .js file as described in an other thread. Just waiting for an official fix.

Can you elaborate on the fix? I’m having issue with dual gauge card.

Hi, answer is here: