Cannot configure/use Danfoss Living Connect radiator thermostat

I’m using HA 0.57.2 on an Olimex Olinuxino A20 with Raspbian Stretch as OS.
I installed HA with pip in a virtualenv (like described on the HA Wiki).
For the zwave part, I use a usb stick Z-wave ZME UZB1.

The stick is seen in HA, when I try to pair securely, a new device is found but it always statys in "Sleeping(Probe) " state.
I tested various method (unpair/pair – factory reset – wiat all the night – test mode – heal network – restart network ) nothing works.
In test mode (from the Danfoss LC) the device wake up in HA and says “Vanne du salon changed to ManufacturerSpecific1” where “Vanne du salon” is the name that I gave to the device…and then goes in “Sleeping (Probe)” again.

It’s the only thing zwave in my home. I’m a bit lost with my first attempt at zwave things. I need help.

Hey D-Fence,

Did you solve the issue (and how)?


No, I was not able to make it work.
It’s really frustrating.
Here is what I did since my last post:

  • I let the nano computer running day and night (in the hope that the device wake up during the night and finish its configuration)
  • I powered the nano computer with a real power supply instead of an usb OTG (in the hope the the problem was the USB device that needed more power)
  • I put the nano computer really near the zwave device (I read somewhere that sometimes, it needs to be really near during network discovery)
  • I also tested without security key (the whole thing, I mean exclude/reset/include/heal)
  • Finally, I tested with other software (Openhab and Domoticz)

Nothing worked but Openhab went a step further, it recognized the device but was not able to change the desired temperature.

Here is an update of my findings.
Finally, HomeAssistant has nothing to do with the problem, nor openzwave.

The problem is DANFOSS !
I bought an LC13 and was confident that it would work out of the box…
but Danfoss does not want you to be free, so they made a new model that does not use the Z-wave standard but a proprietary version … that way, you cannot control it freely, you need to buy more Danfoss stuff that let them enter your home …

So, I stop my angry stuffs, the facts:
As stated here :
there are three version of the same product and one of them does not use z-wave standards.
Here are the model numbers, for reference for other users. The model number is only found on the box of the LC13 ! Nowhere else.
014G0002 : Non standard z-wave … don’t buy that, it only works with other Danfoss products PROPRIETARY !
014G0012 : Z-wave OK
014G0013: Z-wave OK and optimized

So, I’ll try to get a updated from Danfoss … If it does not work, I’ll change and never by DANFOSS again

I have no Danfoss but the “devolo Home Control Radiator Thermostat” which seems to be a modified version of the Danfoss.

On Hassbian it worked well! Since moving to it won’t be possible to be added in the z-wave manager screen in