Cannot connect anymore to my homeassistant via home’s Wi-Fi, while using HA companion app

I’m running an instance of HA on a raspberry pi, wired on my ISP box.

This instance is configured with duckdns and NGINX.

Until today, I was able to access to my HA, from my iPhone, using the HA application configured to connect via :

  1. https://homeassistant.local:8123 when I’m connected to my Wi-Fi
  2. when connected via mobile network or another Wi-Fi network

But since today I’m not anymore able to connect, as soon as my iPhone is connected to my Wi-Fi. I even tried to change the settings, and to force using the duckdns address in all cases, still not OK. Idem if I try using the local IP address.

It is working when I switch off my Wi-Fi connection on my iPhone, but I’d obviously like to use my Wi-Fi network as much as I can.

Something even more strange: using the local address or the local IP in a browser works very well, I can then access my HA, from my iPhone connected to my Wi-Fi.

Any idea what is the problem ?

Hi Cédric, what about if you change the local address in the companion app to https://IP_OF_YOUR HA:8123?

Hi Nick, thanks for your reply. I did it, and still the same problem :frowning:

Have you updated your companion app and is/are the WiFi network(s) not in you configuration anymore?

No, no change in the companion app, the WiFI network is still in the configuration

I managed to connect to my HA ! For a reason I still need to investigate, by activating my VPN and forcing using the duckdns url, I can connect to my HA even if my mobile is connected to my WiFi.

Since it works with a browser on your phone, it seems to be related to the companion app.
You might change your OP by adding the companion app as the category.

What do you mean by « OP » ?