Cannot connect anymore

Hi all,

I’m a new HA user since Feb 2020, so quite a freshman I guess. I’m going to try to explain my issue with simple words. If you wish to provide some advices or ask some more information, please keep in ming that I’m a network begginer, so please don’t be afraid to overexplain like if you were speaking with a 5 year old child…

It is running on a Raspberry Pi 4, wired directly to my router for the network connection. I’m belgian, so my internet provider is Proximus, who is providing their own router (which is a Bbox 3, if that helps).
During up to 2 months I played a lot with HA and had a lot of fun doing my first automations and so on. Everything was working well, that’s why I decided to subscribe to the Nabu Casa service. Unfortunately, it never managed to get connect. After some trials, I finally decided to start from a new HA installation. So I formated the SD card, and reflashed a whole new installation. Then I reseted my router to its manufactury settings.
The installation and updates went fine. The issue happened when I tried to reconnect my mobile phone. It simply doesn’t, find below the only 2 screenshots that I can see when the phone tries to get connected ;

However, I have absolutely no problem to reach HA through a web browser. HA has no worries to download and install updates, add-ons, … When I check HA within the browser after a failed trial with my phone, I have a notification saying the following ;
login fail

and the log generates this ;

2020-04-25 15:34:35 ERROR (MainThread) [homeassistant.components.auth.indieauth] Timeout while looking up redirect_uri https://home-assistant.io/android
2020-04-25 15:34:35 WARNING (MainThread) [homeassistant.components.http.ban] Login attempt or request with invalid authentication from 192.168.x.xx

I tried to reconfigure my router with the 2 options I’ve added in previously (static IP address, and remapping the port) but it didn’t improve anything;

I do not understand as I’ve set the parameters just like before but never managed to make the phone and the Pi talk again. My phone is a Samsung S10 but my gf has the same issue on her iOS phone, so I think this may be related with the router config (correct me if I’m wrong).

Just to let you know, I’ve read a lot of things on the community and did a lot of trials before summoning some help ;
Official guides



Other similar topics


But none of the solution proposed worked for me (or I’m doing them wrong)
Could anyone let me know if this can be solved ?

Thank you in advance for your time and your patience !
Cheers,

Eric

I’m still struggling on this issue.
No one have any idea ?