Cannot connect device

Hey guys! Issue here with a ESP32 and getting the device to display correctly.

Im trying to flash a ESP32, I create the device in ESPHome and download the configuration. I go to ESPWeb and connect, and upload the configuration but each time I do this, it creates and another new device, with a new name called “esp-web-tools-example-de4d68” which is ready for adaption.

If im correct, the device I just created and named, should come online? Hence why I downloaded and upload that configuration file?

If I adopt this device, it sits there and the name doesnt seem to be able to be changed. Also, when this device is adopted, and I add configuration, the configuration changes dont seem to be reflected in HA, I just get the device name and a “Living Room Dehumidifier” which NO WHERE in my configuration did I specify anything to do with a dehumidifier.

Any ideas on how I can resolve this? Ive spent a good 2 hours on it now.

I am flashing via a windows PC, through serial via web browser and any further flashes I am doing wirelessly.


Upon some reading up I see that having GPIO12 connected can cause issues flashing.

I think what may be happening is I have GPIO12 connected to a relay. Is it possible to flash while GPIO12 is connected? Its maybe attempting to flash the board, failing and just reverting back to the previous flash, however, in HA it does not throw a error.

When I tried using the ESPHome Flasher Tool, I get a error saying MD5 mismatch, tried a different ESP32 board and worked flawlessly.

Is there a way to bypass this, im not in a position to disconnect GPIO12

Boot fails if gpio12 is pulled high. ESP32 Pinout Reference: Which GPIO pins should you use? | Random Nerd Tutorials

Is there any way I can force it low when connected?

Why have it pulled high in the 1st place?