Cannot connect Shelly 2 PM anymore

Hello community, I have several Shelly models currently working without any issue. Now I’m facing issue with 4 Shelly 2 PM that worked find until last 3 hours. Other shelly works perfect.
I’m using native Shelly integration and I didn’t update HA or Shelly firmware… I don’t know what happen, and from debug I can read the following:

2023-11-20 20:05:48.409 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] Trying to connect to device at
2023-11-20 20:05:48.427 DEBUG (MainThread) [aioshelly.rpc_device.device] host error: DeviceConnectionError(DeviceConnectionError(WSServerHandshakeError(RequestInfo(url=URL(''), method='GET', headers=<CIMultiDictProxy('Host': '', 'User-Agent': 'HomeAssistant/2023.11.2 aiohttp/3.8.5 Python/3.11', 'Upgrade': 'websocket', 'Connection': 'upgrade', 'Sec-WebSocket-Version': '13', 'Sec-WebSocket-Key': 'RNsXQp5TFdxYZOuT4aRaYQ==', 'Accept': '*/*', 'Accept-Encoding': 'gzip, deflate')>, real_url=URL('')), (), status=400, message='Invalid response status', headers=<CIMultiDictProxy('Content-Length': '20', 'Server': 'ShellyHTTP/1.0.0', 'Date': 'Mon, 20 Nov 2023 19:05:48 GMT', 'X-Cache': 'MISS from localhost', 'X-Cache-Lookup': 'MISS from localhost:3128', 'Via': '1.1 localhost (squid/5.9)', 'Connection': 'keep-alive')>)))

Could someone help me to understand what’s wrong?
Thank you

If your router has multiple subnets, you should check that the router didnt assign it a different IP address.

Nope, I can reach, from HA, via ping the shellies (they have all static ip) and I can reach them also via web page. The only issue is that I can’t configure them anymore in HA.

In the above example, Shelly has as IP and it worked perfect until yesterday.

It looks like you are on the latest HA.
Maybe update the shellys too?

Unfortunately the Shellys 2 PM are at latest firmware

Damn! Fixed.
I had activated the squid proxy on my PfSense and for some unknown reason it blocks connection between GREEN and BLU ONLY for Shelly 2 PM. So that HA cannot reach it anymore apart from ping. This is a very strange behaviour, I need to deep investigate on it.
Sorry to waste forum space!