Cannot Connect to Any Device with IP

Hi there, I’m new to Home Assistant so I’m sure this is user error. However, I can’t for the life of me figure out what I’ve done wrong.

I’ve set up HA on a Odoird-N2+ following this documentation. I’m using a Motorola Surfboard (circa 2013/2014) as my router with a Google Wifi Mesh System for the Wifi. My HA is plugged directly into the router via an ethernet cable as suggested in the doc.

I cannot connect to any device on my wifi network directly with an IP Address. In my troubleshooting, I’ve noticed that I also cannot ping the IP address of any smart device. Additionally my smart devices and HA seem to be on different subnets (Devices: 192.168.86.x; HA:

Documentation suggests this shouldn’t be an issue, but since I can’t ping the devices, I suspect this is the problem. I’ve tried creating a local IP integration based on an issue I read in the forum (lost the link) and have also trie to create a ipv4 route based on this post, but once again no luck.

Full list of testing I’ve tried:

  • HA UI set up for devices
  • Manual YAML configuration
  • Reinstall HA
  • Set up bridge mode on Wifi/Router (not possible with a mesh, router doesn’t seem to have the ability)
  • IP integration
  • Set up ipv4 route

From here, I’m not sure what the next things to try are. Any advice or good search terms I could use would be greatly appreciated!

What do you have in settings-> network → ?


Not sure which specific setting you’d be interested in, so I’ve capture them all (pics below). Please let me know if there is a specific setting somewhere else that may be of interest.


Are you sure? Should that be ?

Again should that be 192.168?

What do you mean by /250?

Yeah, my bad I accidentally transposed the numbers. Corrected in original post, but clarifying down here as well.

They should be:
Devices 192.168.86.x

By the slash I meant the range of IPs on that subnet. TBH, I know just enough about this subject to be dangerous and confusing…

Thanks for pointing that out!

What is the routing? The router is probably not routing packets from 192.168.0.x subnet to the 192.168.86.x subnet.

Is your wifi isolated from other networks since it has different ip range ? Like nickrout said, there might not be routing between. So i would look into router settings.

/250 is an invalid subnet. Did you mean /25? If so, your mask is You probably need to change this to /16 ( As it stands, the subnet is restricting you, unless you set up a routing bridge or change the mask.

@tontze @nickrout @parautenbach

Thanks for all the help, ideas, education regarding networks!

I played around with IP routing and really messed up my internet to the point where I needed to do a hard reset. While doing this, I noticed that the Google wifi point had an extra ethernet port that I had never used :man_facepalming: After getting everything fixed, I tried plugging HA into that and everything started working.

Thanks again for all the suggestions - I really appreciate the prompt responses!

1 Like


Often, the WiFi clients won’t be routed just anywhere (you might see some restrictions or settings for this on your router), but cabled (LAN) clients can.

It’s anyway better to connect you HA host with a cable, so that’s good.

It’s that a normal Ethernet/LAN port you plugged it into? It’s not a WAN port, is it?

Where in the docs? This is definitely two different networks.