Cannot connect to foscam C1 ip cam

Hello everyone,

I’ve just installed HA on a rpi-4 and while it’s been a breeze at beginning, I’m now having trouble with foscam integration.

I have a foscam C1 which has been working well with foscam’s cloud for years, so we can assume :

  1. It’s correctly set up : I have a foscam account (login+pwd) and the C1 has its own login+pwd
  2. It’s correctly wired to the Internet, with reliable, stable ethernet cable

My problem is : when I fill in the form asking for connection info (host; port; username; pwd; stream; RTSP port) and submit it, I get this error message : “Failed to connect”.

I went to HA logs but didn’t find anything useful.

  • host:port should be correct because I found them directly in foscam android app.
  • Camera’s own login+pwd are correct too as I’ve just tried and succeeded in modifying them in foscam android app.
  • For RTSP port, I tried the default (554) as well as 88 because I saw it helped someone else on another topic but no success for me.

I’ve run out of ideas and hope someone here will have the answer!

Thanks in advance for any help :slight_smile:

I have a similar issue. Have you had any luck resolving?

I get ‘invalid authentication’ though. I use the ip for host. If I deliberately put in a wrong IP the error changes to ‘failed to connect’. So I know I have that right. I log into the app over and over to confirm correct user:pass but no matter what I try HA says invalid authentication.

I have similar issues. Does anyone managed to get it work ?

I just wanted to reply that I neither be able to bring my C1 into Home Assistant. But finally it was just a different PW then i use to login via Foscam VMS. Little strange, but i guess this cheap cam has a local user which seems to have a different pw.

So C1 is working now fine for me and this just with default settings. No Configuration.yaml to change or whatever.

Same here. Can’t get it to work with host user and password same as shows in foscam app


I’ve had the problem and I solved it as it seems that it won’t work if you have 12 or more caracters

It worked! The PWD must be 6-12 caracters. I had a longer one.