Cannot connect to hassio externally

Hi all

I was hoping someone could help with hassio on a pi3 and duckdns , I have gone through the configuration of duckdns twice and I still cannot access my device outside of my home network - after I activate duckdns I can access my HA via the HTTPS:// on my wifi but the moment I turn off WiFi and try off network , ie via my cellphone I am not able to connect to HA or even display login. I have checked my wan IP and it is a match for duckdns up, I have given my my pi a static IP and I have tried with port forwarding to 443 to 8123 and I tried 8123 to 8123 (not aT same time though) both with same result, any suggestions out there?

is all you need. You may need to reset your router after turning on a port forward. And finnally, drop the 8123 when accessing the system. it should just be

1 Like

Not all routers can do 443 to 8123. 8123 to 8123 is likely to work on ANY router.

I have a ubiquiti AmplifiHD , I have restarted after each portforward rule has been added (both Hassio and Router)

I have tried the following combinations:

  • 443 to 8123
  • 8123 to 8123
  • 8123 to 8123 and 443 to 8123

With no luck, on both i have also tried to access with and without the port number via the duckdns domain

again it seems to work fine when I am on the same Wifi network, but the moment i try cellular, no page loads

You configured port forwarding for TCP following these instructions?

Hi bosborne, yep followed these instructions, previously had to port forward to get some multiplayer games working

Anyone know what i can use to double check the ports are open? if the ports are not open what other options do I have? i assume it may be a ISP restriction?

Try a tool like this.

Not sure what has changed in last 8 hours but I came home and tested it and it worked using 8123 to 8123, time to test the google assistant integration

1 Like

That means it also works with 443 to 8123 w/o using the port. I’m guessing you were clearing the cache during each attempt, or you weren’t waiting long enough for the port forward to take effect.

Not necessarily. On some home routers that does not permit inside network access by name.

Listen, I get it. But his router allows it.

I ended up changing it to 443 to test and it still works :raised_hands:, but now I have a issue trying to get it to link up to Google assistant manually :joy:, another roadblock, had to post a separate topic for this

I’d help ya but i’ve never done it myself.

I had similar problem, i spent 3 days troubleshooting and it turns out that it was an ISP issue.
My isp has two ranges of IPs, one that allows remote access and one that doesnt.
I had to call them up and they told me: “just a sec, let us give you a different IP” and everything worked.

1 Like

This tool may be useful to you.

Yeah, that tool confirmed that my port was closed zbut I couldn’t figure out why, all my settings were correct :slight_smile:

This happens if the equipment to which the port is redirected is disabled … for example :slight_smile: