Cannot connect to host ssl:None [Connection refused]

Hi all,

Does anybody know, why I get this error in my hassio log all the time?

19-01-15 01:56:39 ERROR (MainThread) [hassio.homeassistant] Error on call Cannot connect to host ssl:None [Connection refused]
19-01-15 01:56:39 ERROR (MainThread) [hassio.api.proxy] Error on API for request services

Here is a github issue, for anybody also having this issue:

I know this is an old post. But I had this problem with the last HA update. I found a solution:
The problem is caused by a conflict in the ports

  1. Stop all your containers except Portainer and HA + HA supervisor
  2. Check if that solved your problem. If so… continue to point three.
  3. Activate one of your Docker containers and check if the problem persist.
  4. Repeat number three until you find out which one is the container that is conflicting with HA.
  5. When you find it, just stop the container and change the ports in which the container is running.
  6. enjoy.

how do you change docker ports?

there are different options, Docker Compose, Portainer or your server console.

I have looked everywhere, I dont see these?