Cannot Connect To my Raspberry pi

i just bought my raspberry pi 4 2gb and downloaded hasos. I tried to connect via http://homeassistant.local:8123 and http://homeassistant:8123 and its ip and x.x.x.x:8123 but i couldnt connect. i tried the homeos 32 bit or 64 bit version it didnt changed.

Does your home assistant IP show “active” on your router. Stick with the 64 bit version. Do you have a display on your Pi…it helps to have one when you’re installing, just in case there are messages. Finally, it does take a little time before the pi reacts to your request…leave it started for 10 minutes and then try to connect using the ip:8123

it shows active, i looked with the display it says Homeassistant login: & password. i tried loging in but it doesnt allows me to login. i left it 15 min running and tried its ip address:8123. its stuck on the login screen.

It is normal for the display connnected to your Pi to sit with a login screen…but that’s to get to linux, not to get to home assistant and there is no reason to log in on that screen. Home assistant is accessed through a browser on your network (not the Pi) and the URL you use in your browser is http:// xx.xx.xx.xx:8123 .

Is the browser not showing the home assistant screen?

Hi Brains trust

Unable to connect to http://homeassistant.local:8123/

I have done a fresh install of the 32bit on RBpi. (OS5.12, HACore 2021.3.4)
When I login into HA on the Pi it confirms the IP address etc - Can run cmds from within Pi like DNS Restart)
I have done a reset of my Orbi so back to default. NB It used to work fine before it just stopped
I can ping both the ip address of the Pi and http://homeassistant.local:8123/ from my laptop
I cannot access the URL from either browser on any windows device or app

Run out of hair to pull out so looking for help here please :slight_smile: