Cannot connect Xiaomi Gateway (lumi.gateway.v3) to MiHome App

Tags: #<Tag:0x00007f3268d223e0> #<Tag:0x00007f3268d222f0> #<Tag:0x00007f3268d22110> #<Tag:0x00007f3268d22020>

Hi,

I have Xiaomi Gateway which I’m unable to add to the MiHome app in order to enable DevMode/LAN mode and proceed further with HA and some Zigbee devices.

What I’m doin is:

  • downloaded fresh app from store

  • choose “China” region - otherwise it cannot detect the device.

  • push the button 5sec - it blinks yellow

  • The device is publishing an open WiFi network: lumi-gateway-v3-miap9709

  • I was forced to share my location and search “nearby devices” | not working if I trying to choose from list of devices.

  • After the device is magicaly detected nearby and I’m asked to choose network and give the password. Done. Next.

  • My phone says it trying to connect to device. I can cee WiFi ich changed. I bet it’s connecting with the network the device is broadcasting. Success.

  • Nest step is “send message to device”. It finishes quickly. Yellow light stops, blue for a moment, then no lights and it talks something. I can see it’s connected to my router.

  • the app is on last step: “Connecting device to network”. I see the phone connected back to my Wifi, thinks a while and then the step is failing.

  • This is my first installation. No other devices. The app is empty.

  • I tried to remove all data from account by declining GDPR and trying again - the same result

  • I created new account in the app - the same

  • I tried 2 Android phones: Xiaomi and Samsung

Does anyone have any ideas what I can do ?

I had the same issue as you for a week and suspect the problem to be with my Internet Service Provider (ISP). You can try this work around (works for me) but not sure it will work for you,

  1. Use mobile phone A to create a hot spot (using internet from your SIM CARD) with the same SSID and password as your router (2.4ghz). Remember to off your router to avoid conflict.

  2. Use Mobile phone B and connect WIFI to the hotspot of Mobile A.

  3. Launch Mi Home App from mobile phone B and pair the gateway. Once completed, you should see the gateway on the app.

  4. Disable the HotSpot and Power ON your router to let gateway connect to it. You should also see the gateway appear on your router via login page.

  5. Restart your Mi Home App on your Mobile B and try and see if you can control it. If it works, it should auto sync to all mobile devices via your Mi Home account

Hope the above helps.