Cannot create automations/scripts in the UI - Google Chrome

Hello there

I tried creating a script recently through the UI, but when I click on “Create new script”, nothing changes and the UI feels kind of ‘broken/frozen’ (I have to click around to exit the script page.
Screenshot 2024-06-12 at 11.46.40

I cleared my browser’s cache, without success. I use HA with Chrome, but when I open it in Safari it works just fine for some reason… I’ll use Safari for now, but I would rather use Chrome in the future.

Here’s my configuration.yaml file if that helps:

# Loads default set of integrations. Do not remove.

# Load frontend themes from the themes folder
  themes: !include_dir_merge_named themes

# My own handmade automations
automation manual: !include_dir_merge_list automations/

# Automations I create in the UI
automation ui: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Many thanks

does it fail in chrome if you try it in a fresh profile view? (hit your profile in the top right of chrome, go to guest under “other profiles” section.

1 Like

Just tried it and it works just fine with a guest profile! Do you have any idea why?

I know you said you cleared cache but it’s almost certainly some profile cache data that didn’t get properly cleared.

I’d shut down chrome 100%. check the process list to make sure there are no hidden instances. then clear browsing data. Then close the process and reload. If that doesn’t do it you may need to manually blow away the profile store data.

1 Like

Do you mean for Chrome or HA?

I’ll give that a shot and update this post once I’m done. Thank you

chrome. the issue is in your local chrome profile storage.

1 Like

Ok so I went ahead and cleared the cache + history + cookies for the past week on my account, without success… I still have the same issues. Surprisingly, I have the same issue on my personal account, but not on another google account I have on my machine.

What did you mean by this?

I can access my ‘Default’ profile locally, but I don’t which files I would need to ‘blow away’ + what it means exactly. I appreciate any tips/pointers you may have!

Thanks a bunch

before we hit that drastic step…is your chrome profile synced using chrome sync? if so, do you have another laptop that you’ve tried this on but using chrome and the same google profile?

if it fails on another laptop, then it’s something in your cloud profile and that gets harder. if it works on another laptop with the same google profile while profile sync is turned on, then it’s more and more likely it’s a local problem to that one profile on that one machine.

could you clarify what you meant by this:

do you have multiple chrome profiles for which this same thing happens?

Yes, it’s synced.

Just tried on another computer with the same profile + sync on and it works just fine!

And yes. I am using my main Uni account to run HA. I have also tried on my personal Google account and I run in to the same issue there. I then tried on another account (alumni account from previous university) and it worked just fine there. If I remember correctly, I synced my personal data to my Uni account at some point (e.g., I share passwords across both accounts) - maybe that could be why I have this issue on both accounts?

So if I understand correctly it must be a local, right?

are you on windows? or mac?

everything you’ve described really sounds like it’s local to your machine.

since you sync your profiles, and clearing cache doesn’t do anything, the next thing i’d do is getting more drastic, but it’s deleting and recreating your chrome profile.

profile button on the upper right->other profiles settings (the gear icon to the right of “other profiles”. here you can create a new profile and delete the existing one.

this is kinda a big hammer so i really hesitate to suggest it. it’s not the biggest hammer… but it’s close.

1 Like

Mac OS!

I’ll go ahead and do that. Are they any drawbacks to doing that? I already have sync on so it shouldn’t be a problem, right?

And I guess it would be nice to know why this happens so that I can prevent it from happening in the future. Do you think I should circle it back to the dev team somehow?

yeah, it’s annoying not to know why it’s happening. but without more diagnostic data the chrome engineers aren’t going to be able to figure more out. and if it’s not wide spread, it won’t be high priority to fix either.

Ok so I deleted my account from my computer and reinstalled it + use sync to have all my data back, and I still get the same error…
I think I’ll just go ahead and use another web browser atm and just accept that it won’t work perfectly on this account.

before you synced it… did it still fail? or did it only fail after sync? i gotta admit, this is pretty baffling…

It worked before I synced, I had to re-try to verify. And it didn’t work after I synced however.

I also tried to restart my computer earlier just in case. I’m really confused.

huh. i discounted sync bringing down an issue because you previuosly verified this:

but what you just said that it works until you sync makes me question the above. and perhaps you have some privacy setting blocking things. something in this: chrome://settings/privacy that’s restricting home assistant.

as a horrendeous workaround, does this work:

http://your home assistant url:8123/config/script/edit/new


Yes this works just fine. Forgot to mention it, but this is also what I’ve been doing. It works just fine, it’s just a slightly annoying workaround.

I am going to flag this as the solution for now.
I’m not sure what else I can do at this point, I’ll just type in the address manually everytime.

Thanks for your help with this!

well… if you’ve become convinced that something syncing is what’s causing you problems, and you’re willing to invest the time, you can go here: chrome://settings/syncSetup/advanced

and turnoff things that are getting sync’ed. it’s tedius, but the process is… turn off something to sync, delete your profile, log into the profile but don’t enable sync, make sure homeassistant works… then turn on chrome profile sync… wait till it’s done syncing. see if it breaks. that should start to narrow down what’s breaking you.

i’m going to guess that it’s most likely extensions or settings. once you figure that out, if it’s an extension, that’s a little easier because you can easily turn on/off extensions. if it’s settings, that’s much harder, but it points you in the right direction… sorry we weren’t able to actually get to the root of this.

1 Like

I’ll have a stab at that and keep this thread open if anything comes up. And it’s alright, thanks so much anyway! I’m sure we’ll be able to figure it out somehow :slight_smile: