Cannot edit resin-sample

I have booted HA, but i want to static assign IP Ethernet address.

I moved SD card back to PC, opened resin-sample. but am not allowed to save or copy and past or rename the file.

How do you fix this issue please?

What I did was set my router to lease the dhcp ip address that’s given out to ‘forever’ so each device always gets the same ip address.

Thanks, I think I am giving up on Hass, three days work and I have a Raspberry pi I can SSH to. Cannot get any zwave stuff to work at all.

Hmm Zwave should be easy, all you have to do is add the nodes (and if battery operated wake em up with the button).

I add this line to YAML

usb_path: /dev/ttyACM0

I get

Failed config
General Errors:
- Component not found: usb_path
- Setup failed for usb_path: Component not found.

I love the idea of it all, and the youtube vids are great but some are way out of date.

The error message says it all really, it should be AMA0 for most Zwave usb sticks. Sometimes if you pull it out and put it back it will go to AMA1 but you shouldn’t be doing that anyway :slight_smile: And there is a way round it by using usb_by_serial.

sorry, should that read in the YAML file?
I copied what I used from a article,but I cannot find it now.

usb_path: /dev/ACM0

usb_path: /dev/AMA0

I dont get it? same error, where does AMA0 come from? why does tons of posts say zwave:
usb_path: /dev/ttyACM0

It is like you need to know this, thanks for your help.

Any way same error

I think it depends of the stick, they can come in as 1 of four values ACM0/1 or AMA0/1, a lot seem to use AMA0 but mine is actually ACM0. With it’s a bit more difficult to actually tell where it is as you don’t have easy access to the underlying OS. However there are only 4 potential candidates :slight_smile:

Can you believe this document, Enabling zwave with Hassio

This is where I found the following

usb_path: /dev/ttyACM0

Here’s what @NotoriousBDG had to say about finding your zwave connection…
For hassio, run hassio host hardware while you’re ssh’ed into the ssh addon and you should see the list of serial devices visible by your hassio machine.

core-ssh:~# hassio host hardware
“result”: “ok”,
“data”: {
“serial”: [
“input”: [],
“disk”: [],
“gpio”: [
“audio”: {
“0”: {
“name”: “bcm2835 - bcm2835 ALSA”,
“type”: “ALSA”,
“devices”: {
“0”: “digital audio playback”,
“1”: “digital audio playback”

Ahh my fault I was looking at the Razberry board :stuck_out_tongue:

So it could be anyone of those three depending on your hardware I think.

Right back to

usb_path: /dev/ttyACM0

And now it works, thanks for your time.

Glad you got it sorted :slight_smile: