Cannot find what is taking up space on my install

Currently my disk usage is showing about 22gb used. But a full backup is only 3.6gb. Just today I migrated from my old installation on a 10 year old laptop to a VM hosted on Proxmox. I restored from the 3.6gb backup, and now my VM is also showing about 22gb used, which is just baffling to me. I find it hard to believe that whatever compression software is being used is able to compress 22gb down to 3.6gb.

To be clear, it showed approximately 22gb used on the laptop before the migration as well.

I have tried using ncdu, du, and df commands in the home assistant terminal, but I get no clear results. Admittedly, I am not particularly familiar with Linux in general, so I can only approach this the same way I would on a Windows machine. If I had a similar issue on a Windows machine I would use something like Tree Size to drill down from the root and identify where all the space is being used.

From what I found online, ncdu, du, and df commands are a reasonable approximation of TreeSize. But the results I got from those commands dont make sense to me.


The space is being used on sda8. After a quick bit of researching I now know that “sd” is a scsi device, “a” is more or less the first one (aka first hard drive), and 8 is the partition. Great, so its using 22gb on the first hard drive on the 8th partition. I also understand that the paths shown to the right are sort of like the folders found on sda8. unfortunately, df -h did not tell me the individual folder sizes, just that the partition they are on has used 22gb.

so I ran du -h against each of the mount points on sda8. None of them were the issue, and they also do not add up to 22gb combined. I decided I would try and mount sda8 to /mnt because what I really want to do is just browse through the partition as a whole and see whats in it, but I get permission denied when I attempt to do so.

I feel like I have to be missing something obvious. It cannot be this hard to track down what is taking up space on a partition.

Any assistance would be appreciated!

Given you’ve got folders like /homeassistant there, I’m guessing you’ve used an SSH addon to connect. You are therefore inside a docker container, and can only see what it lets you see. You would have to connect to the HA host machine directly, or by enabling SSH to port 22222. There is also an addon to simplify enabling port 22222.

Before the migration today, I had installed HA OS directly on bare metal on the old laptop. Its very possible before I really figured out how to use HA, I probably tried connecting with Putty or something to try and do something or another. Not sure if that would have created the folder you are talking about or not. But I can fairly confidently say that HA itself was not inside a docker container.

With the above clarification, does that change your opinions? I am not very familiar with docker. I know HA uses it for its addons and such, and I know there are ways you can run HA in a docker container, which then removes HA’s ability to handle addons, but that’s about the extent of my knowledge. I’ve never used or interacted with them in a direct way. I’ve just let HA handle it by using the Addon store.

if you think that connecting via SSH is still the best way to go about it, I will give that a shot

HAOS is the Operating System, and Home Assistant runs in docker (there are a number of docker containers including one for supervisor). Every addon runs in its own docker container. The only version of HA that does not run in docker is Home Assistant Core.

How are you connecting to the terminal? If it’s via SSH, then you’re doing so via an addon, and therefore you’re inside a docker container. Since you’re using Proxmox, you can just use the “Console” tab:

1 Like

Oh, I had not realized thats how HAOS worked. Also, upon further inspection, yes I appear to have installed the Terminal & SSH addon at some point. I was accessing it directly in chrome from the web portal. I had thought it was part of the normal tools, I did not realize I had installed it as an addon.

but trying it from the console in Proxmox makes sense. I will give that a shot after I fix my HASS VM’s console… It currently doesn’t work because I used PCI passthrough to pass the HASS VM the integrated graphics from my CPU so that the Frigate addon could use it to speed up object detection :sweat_smile:

I dont think I need help with that though, I had already found some guides online that said the console stopped working because the VM is outputting to the Integrated Graphics instead. The guides show how to get the VM to output to both the console and the integrated graphics.

Once that is fixed, I will try poking around in the Proxmox console instead. Thanks for the help!

Yes, the Terminal option in the menu is put there by the SSH addon.