Cannot get addon config map to work

I’m currently trying to setup a hassio addon that contains the deCONZ software for the Raspbee shield. I’m already pretty familiar with Docker and somewhat with the config.json and build.json

I’ve gotten as far that I have a running Docker image in hassio (build locally) and connected the GPIO and the needed devices from the host to the docker image using the configuration. So I am able to run the deCONZ software and it recognizes the Raspbee shield. So I was happy with that.

The issue is that the deCONZ software creates an SQLLite database file in the container, which of course gets erased upon restart. I know that hassio supports a map in the configuration to link host directories to the docker image, but I cannot get it to work.

In the docker file I’m exposing two volumes, being:

VOLUME ["/share", "/config"]

The build.json contains the following

  "build_from": {
    "aarch64": "arm64v8/debian:stretch",
    "amd64": "debian:stretch",
    "armhf": "arm32v7/debian:stretch",
    "i386": "i386/debian:stretch"

What I’ve got in the config.json is:

  "name": "deCONZ",
  "version": "1.0b-1",
  "slug": "deconz",
  "description": "A compatible installation of the program for the Zigbee rpi shield created by",
  "startup": "services",
  "boot": "auto",
  "map": [
  "options": {},
  "schema": {},
  "url": "",
  "ports": {
    "8080/tcp": 8080,
    "443/tcp": 443,
    "3389/tcp": 3389
  "gpio": true,
  "devices": [
  "webui": "http://[HOST]:[PORT:8080]"

I would expect the share and config to be mapped to ‘/share’ and ‘/config’. But they are not and I cannot figure out why? Can someone help with this.