Cannot get ios component to load

I’ve been trying to resolve this for days. Both manually by many means and also by using the integration.

My config.yaml is below. If any one can point out my obvious mistake I’d really appreciate it.

  elevation: 192
  unit_system: metric
  time_zone: Europe/London
  customize: !include customize.yaml



# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true


  - platform: life360
    username: !secret life360username
    password: !secret life360password
    prefix: life360
    show_as_state: driving, moving, places
    driving_speed: 18
    max_gps_accuracy: 200
      minutes: 45
    interval_seconds: 10
    add_zones: true
      minutes: 15
    filename: life360.conf

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time

# View all events in a logbook



  - platform: google

        - script.lounge_tv_off
        - script.garage_door
        - switch.garage_door_opener
        - script


# arlo:
#   username: !secret arlo_username
#   password: !secret arlo_password

# alarm_control_panel:
#   - platform: arlo
#     home_mode_name: disarmed
#     away_mode_name: armed
# camera:
#   - platform: arlo

  - name: Prowl
    platform: prowl
    api_key: !secret prowl_api
  - name: neil_prowl
    platform: prowl
    api_key: !secret neil_prowl_api
  - name: iPhone
    platform: ios
    target: !secret ios_ash_x_push_id

  - platform: darksky
    api_key: !secret dark_sky_api


    title: TasmoAdmin
    icon: mdi:lightbulb-on

    title: IDE
    icon: mdi:code-braces

    title: MDI Icon Index
    icon: mdi:vector-square

group: !include groups.yaml
alert: !include alerts.yaml
input_number: !include input_slider.yaml
script: !include scripts.yaml
binary_sensor: !include binary_sensor.yaml
switch: !include switch.yaml
sensor: !include sensor.yaml
input_boolean: !include booleans.yaml
input_select: !include input_select.yaml
#ios: !include ios.yaml
cover: !include cover.yaml
automation: !include_dir_merge_list automation/
zone: !include zones.yaml
variable: !include variables.yaml

The # infront of ios: will prevent it from loading.

Thanks, but I’ve tried it with and without and laos with and without the integration option.

I think I’ve covered all variations with no success.

I’ve now been through my entire config and removed every ios reference.

I’ve restarted Hassio and then used the integration tool to add the iOS component, which it says it has done.

A restart then brings up the iOS failed to load error.

Can you post the error?

Here’s the error I get:


And this:


I should have used reply!

What is in your ios.yaml file? It’s like 1 line… why are you breaking it out?

I’d start there… just remove the include and have only this:


I’ve tried that a dozen times. It makes no difference. I’ve commented it out along with everything in the ios.yaml file. It just contains my ios actionaable push notifications.

I have no references to ios anywhere.

I’ve tried removing discovery: and it still looks for the ios component and creates the error.

There’s no iso.conf file and no hidden file either.

Does adding ios: in the config.yaml file deliver the same result as using the integration?

The docs say:

The ios component will automatically be loaded under the following circumstances:

  1. The discovery component is enabled.
  2. You have just installed the app and are at the getting started screen.

Is this still correct since the addition of the component integration feature?

The docs also say:

Loading the ios component will also load the device_tracker , zeroconf and notify platforms.

I am seeing the device tracker component loaded in the iOS app but not the Notify platform or the iOS component.

Where does the iOS component get loaded from? Is it downloaded or part of the HassIO package?

If you read further than what you quoted you will see that it says for subsequent starts you need ios: in config yaml file.

I suggest:

Comment out the ios: line in config and remove that include ios.yaml part altogether.

Remove the ios integration.

Reset the app on your iOS device.
Force close the app

Restart home assistant.

Uncomment ios: from config yaml
Restart home assistant.

Run the app (the BETA version) and authenticate with Home Assistant.
Have a look and see if it has automatically added the integration.

Have a look for .ios.conf a hidden ‘dot’ file on /config/ folder.

In the app, when you logon, don’t use any advanced settings. Just input your Home Assistant URL and click save and it should lead you through logging onto home assistant.

After first logging on I normally force close and load again. Check the settings>notification settings and click on the push I’d one. You should see the same push ID there as is in the .ios.conf file - it MIGHT take a few minutes for it to sync up.

You should also be able to push using the up arrow in the bottom left corner your location from ios to home assistant.

Thank you, David. I’ll give it a try tomorrow. It’s nearly 02:00 here already.

Thanks, David. I followed all of those steps, screenshots below.

Still the same. iOS component fails to load. Any idea where to look next?

I appreciate your time.

So you do have an .ios.conf file… what is in that? Can you show your config yaml? Have you tried manually adding the integration for ios? (Config->integrations)

The .ios.conf file is empty.
The config.yaml is in the first post.
I have tried manually adding the integration. To no avail.

So, up early this morning and I set about creating a new SD card for a new instance of HassIO.

Running 2 RPis, I then copied over the contents of each file and element of config.yaml one at a time, restarting between each and checking if the iOS component was still loaded and that the app was still showing the component on restart in an effort to identify where it breaks…

I’ve just finished and…

… it seems to be fine.

So, no further forward in my understanding of what caused this.

Many, many thanks for you your time and help.

OK so are you able to access your HA externally at ALL even from a Web Browser? Your 10.0.x.x IP address looks to me like CGNAT - carrier grade NAT and if so, you do not have a real routable IP address and external access will be impossible. Does your ISP provide IPv6 native/dual stack?

That’s just my internal IP address from my Apple router.

No idea. It’s not something I’ve had a need to explore so far.

All I need is the notifications when outside my home network and they work fine now.

Thanks again for your help.

1 Like

Glad it’s working now…

1 Like