Cannot get notifications working with Companion 2.0 (69)

I have tried all the steps I’ve found on these forums to restore working notifications, but to no avail.

Since moving to the 2.0 companion app my phone has stopped delivering notifications, though my wife’s continues to work.

Troubleshooting steps thus far have included:

  • removing the devices from the integration page
  • removing the app
  • disabling and re-enabling the Home Assistant Cloud
  • creating a new user with different password
  • logging in on a different device, such as my iPad

None of these steps have restored notifications. Another clue is that I regularly get a 404 error when re-connecting the Companion app. I enter the Home Assistant Cloud URL and it says, “Error: response status code was unacceptable: 404.” I can usually force it to work by toggling the cloud and removing/re-installing the app

Note that I have also ensured that iOS is permitting notifications and have clicked ‘ import push configuration from server’ in the companion app (though I don’t know what this means).

What other troubleshooting steps can I try?

please ignore, hadn’t seen your last sentence…sorry
you did also use the Push-id ‘Recover’? (‘Herstel’ in Dutch)

Note that you shouldn’t use notify.notify any longer, but use the notify.mobile_app_deviceid service
Your wife might still be on 1.5 on which the notify.notify is still a working service (it will/should/could still work on 2.0 if you havent deleted the iOS.conf file … a little hack for now)

Thanks for the response.

I don’t see a notify.mobile_app_deviceid_service in my list of services.

None of these device IDs are those of my phone.

Also, why has notify.notify been deprecated? Is there another way to send a notification to all users without individually enumerating them?

yes create a noitfy group

  - name: IOS_FAMILY
    platform: group
      - service: ios_megneli
      - service: ios_meghans_iphone

call notify.ios_family

Thank you. However, I still have the issue that my device does not appear in the drop down. Is their anything I can do to ‘force’ it to show up here?

Did you follow the upgrade steps? Did you add:



to your configuration.yaml and restarted ?

No! I missed that. Where do I find the upgrade steps for future reference?

Trying it now…

According to this page, mobile_app: is enabled by default. I haven’t removed default_config:

Do I still need to add it?

It worked!!! Thank you thank you thank you