Cannot get to home assistant after changing ip address [Solved]

Hello eveyrone. I am very new to home assistant and am running on a raspberry pi. It is POE and I have been able to the to it via web interface. I wanted to set a static IP address and when I changed it, I can non longer get to the web interface. I don’t have a keyboard or monitor hooked up to it. I cannot ping the address but when I run an IP scanner the address that I set as static shows up. Not sure what to do next.
Thoughts? Thank you for any help in advance.


If you connect a screen to your rpi you’ll be able to see the IP address it is using.

Is it possible something else also has the same address?

Is the rpi IP address on the same subnet as all your other devices?

I’ll start with connecting a screen. There is nothing else that has the same IP address. I am running my iot on and my regular network on I have no problem getting to machines on either network from either side. Thanks for the help and will post back once I figure it out.

Thanks. I was able to see that the pi was on the address that I statically assigned to it. I used nmcli to change it to a static assignment of the previous IP and now I can get to the machine via web interface.

Right now I am on

Home Assistant 2023.6.2
Supervisor 2023.06.2
Operating System 10.2
Frontend 20230608.0 - latest

I would like to change my ip address to a different network that has dhcp assignment for HA. Given that I now have a static IP (be it the original one) how would I do this? ELI5


Though this might help too

I was able to switch back to DHCP and so I can set the IP address that will get handed to this machine from my managed switch.

1 Like

Did you remember to change the gateway when you switched vlans? What about your switch? Are you doing vlans on there, or do you just have a dumb switch? If you’re doing vlans, did you remember to change the vlan assignment on the port? So many things it could be, and Not much information to go on here…

Thanks for the reply. You are right. Lots of places to check. I have a managed switch and run vlans. I Was able to put HA back into dhcp mode and set the port to only the vlan that I wanted for my IOT stuff so now it is getting an IP on this vlan. So all is solved. I do think I want to assign it a static IP and am going to do this at the router level so that IF I need to move it to another place, it will get a different IP address and I should be able to get to it (for example my IOT network goes down and I plug it into random non-managed port). I will mark this as solved!

Makes sense, but that’s not a static ip; that is a dhcp reservation.

Right again! I appreciate the clarification. :slight_smile:

1 Like