Cannot install addon's or update to the latest

I tried installing official community addon’s, and it fails with:

blocked from execution, no host internet connection`

What is weird was I was able to do the on-boarding no problem, weather also on the dashboard is functioning. It seems the components to download addon’s or even update HA does not detect they have internet access.

I have tried using this in a VM along with a Raspberry Pi 3b+. The device has a static IP, and DNS is set to (tried as well), no luck. Using HAOS 9.5 as the OS.

Any idea where else I can check? I seen numerous topics on this, but none of the solutions seem to work for me.

Did you set them VM’s to access the Internet?

1 Like

Yep. I can access the console, and execute the following:

ping is alive!

I also had the same issue with my Raspberry Pi using HAOS hard wired into my router.

Well, to help need more info. Your reply is meaningless without more context. I do not know if that is from the host machine or the VM internally or the PI? Start from the beginning and layout the complete details. No into playing wack-a-mole.

What is host and os (with version)
What is the VM (with Version)
HA in the VM?
Sounds like a piece meal installation versus a package, so what instructions (sites/links) did you use.

1 Like

I am not aware of any ping command that replies [target address] is alive! so I call nonsense.

1 Like

Fair enough, I have not seen that before either. But it does:

Hello @lordwizzard,

Apologizes for the late reply. You are right, I should have included more information.
I was using my Raspberry Pi, I even tried to rule out a few things and spun up the OVA in VirtualBox.

The OS Version: Home Assistant OS 9.5
Core: 2023.3.5
Running on Virtual Box Version 7.0.6 r155176 (Qt5.15.2)

The instructions I used was from the official website:
For the Pi: Raspberry Pi - Home Assistant

For VirtualBox: Alternative - Home Assistant

No proxy, basic firewall built into my router.

Edit: Let me know if I missed anything.

There is an error caused by recorder.utility which talks to the database for history. It should be with the HA where have you set that up.

Then it isn’t seeing the internet. So that would be in the network section of HA. Could be caused by the VM not seeing the network via the Host computer and network setup there. So start with the host and does it have full unlimited network/internet access. Then the VM is the next place to work on the network settings for full unlimited access. Then the HA network settings.

This is all on a VM so you need to allow the VM to the the network via the host it is setup on.
You have not identified the main host. I see the VM given only.

1 Like

The Host that I am running Virtual Box on is Windows 11. Using a hardwired connection to my router.
Network adapter is set to Bridged Adapter to my NIC Adapter.

The host has full unlimited network/internet access. The VM at the console has internet access as I am able to ping via DNS or IP, I also did a curl to and was able to get the contents.

I did try a curl to and it fails:

OK when I click on the in my web browser, I get a reply that the “Network Manager is online”.

Are you signed into the community web site at the same time?

So do you have a web browser available on the VM to try the web and see that response?

Web address:
Screenshot 2023-03-28 at 23-03-01 Screenshot

Also are you signed into the HA github via you github account?

No, I am not signed into the community web site at the same time.
I get a successful response from the host (Windows):

NetworkManager is online

The VM is running Home Assistant OS, and no way to install any additional packages (apt or apk).
I did try this and it was successfully (ruling out somehow 80 outgoing was blocked)


Nope, I am not signed in HA github at all.

Well you need to have accounts setup on either HA or Github in order to access downloads and updates using api keys or the installation ID that is made during the installation of HA.
It is a way to keep the spammers and disruptors out of the software development.

Hmm, I didn’t see anything mentioned in the Getting Started section of
I checked advanced configuration and on-boarding. So I need to sign up for github or and put those credentials inside Home Assistant somewhere? I see a place for HA Cloud, but that is it.

I also enabled IPv6 after reading other similar posts, but no difference.

No you do not need to set up an account anywhere to install home assistant.

Thank you @nickrout, okay so I am back to square one. :frowning:
Anything you can think of for me to check? I did all the suggests I found while searching for similar topics, such as setting my DNS to or, including my router. I have assigned a static IP, I even turned on IPv6 on my router as I had it disabled.

I am having the same problem running latest version on Hyper-V VM. Getting internet connection no issues with websites or ping. can download 3rd party addon fine just not the official ones.

Okay check your Windows Defender protection for downloading software from sites and the firewall settings for ports.

no windows defender or firewall settings as its running Linux and it VM container

There is a firewall on Linux. (firewalld most likely). Then there is iptables. Netfilter, UFW. So lots of possibilities there.

MTU issues this fixed my issue

ip link set dev eth0 mtu 1200