Cannot integrate Smarthings with Home Assistant - 500 error

I bought my first Raspberry Pi yesterday and I’m completely new to HA and trying to get it setup. Any guidance or suggestions would be appreciated. Details of what hardware and software I have are included at the end.

The error message I get:
Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble

The things I’ve tried so far:

Initially I was able to enter a Smarthings Token code but it was not accepted. I tried a few things and now I just keep getting the 500 error message

Raspberry Pi 4B
TP-Link Archer C60
HA OS v9.3
_Core 2022.11.0
Nabu Casa trial account
_Remote Control active
_Webhook for SmartApp (smartthings) active

Did you ever get this resolved? I have the same issue, same scenario. Just loaded HomeAssistant yesterday, was going good until i tried to enable the Smartthings integration. Same error as you, though I have never made it past the initial step.

Did you try the troubleshooting steps under the Smartthings integration docs?

If so - where is it getting stuck?

You may have also inadvertently installed multiple instances. The Smartthings integration creates a small smartapp on the Smartthings API - it is not a “groovy” smartapp but uses the new structure. See my post here about installing the Smartthings CLI to see what is configured on the Smartthings side and to delete extra instances of the Homeassistant app that runs in Smartthings.