Cannot login online configurator


#1

Hi, I’m a newbe concerning HA. Just got it up and running on my R.Pi running the latest Hass.io and managed to link it to my Sonos speaker and to my Fibaro HC2, to get some exercise. I found it nice to be able to make online (http://IP-address:8123) changes to the config.yaml file. Every time I made a change, I always check using Configuration > General > Configuration validation > Check config, before I save any changes or reboot. No problems so far.

But today I couldn’t get into my config file (http://IP-address:8123/configurator). The system asks me user name and password, but when I enter the administrator credentials, I don’t get in but get the message “Policy not fulfilled”.

What is going wrong here? Did I do something wrong?

BTW: I use a Mac and didn’t find out yet how to read any files on the micro SD card. Can’t access them or read any of the contents, let alone alter any files this way. Should I use a specific program for this?


#2

And I also got smb sharing of the contents of the SD card working. That’s great to manage the HA!

And the HA is still running, but smb sharing nor the online configurator work. When I try to establish a connection to smb://hassio.local/ I get a message stating something like "A problem occurred with the connection to the server ‘hassio.local’. The same happens when using the IP-address instead of hassio.local.


#3

That error usually indicates that you client IP is not within what is configured in the list of allowed_networks.


#4

Thanks for the suggestion, but as described everything worked first and the next day it didn’t anymore. All components are on the same LAN (same subnet).

So, any other suggestions?


#5

The other case where this message appears is when the client IP has been banned. That too would be visible in the logs. So to make any progress, please post the log of the configurator. It will tell you what the problem is.


#6

OK, So I am also a newbie and fell for the same thing,

It happened to be that I was not remembering the password I set correctly.

Go to “Hass.io” on the left menu, Select “Configurator” Add-on that you previously enabled.
Scroll down to the ‘config’ text box… you will see what user ID and password you defined when you setup configurator Add-on.


#7

Thanks, @groutley. I did exactly what you describe, but when I go to to ‘ Configurator’ in the left menu, I get the message “no auth header received” straight away. I can’t find a way to enter username and password again. That’s the main problem. The credentials I entered were correct, so that is not the problem.

Anybody any other suggestions please? I’m getting a little desperate…


#8
  1. Try opening the configurator in a separate tab. Maybe even in wahtevery privacy-mode your browser supports. There you should be asked for the credentials again.
  2. Set the username and password to something else to invalidate previously cached credentials.

#9

Thank you Daniel for your help. I just found out that I can reach the configuration files using the browser. I didn’t think of using that way. I used the app (on iOS) and in the menu selected Configurator. Doing that I get the message “no auth header received”. I didn’t have that problem in the beginning…

So the problem not getting access to my configuration files is solved luckily.


#10

Hmm, just found out what causes the problem: accessing the HA using the web address http://hassio.local:3218 leads to the mentioned error message.

Using the address http://IP-address:3218 works fine.

Now I know this, but I’m still wondering what causes it…