Cannot login to the home assistant GUI after HA restart

Current Config:
Core 2024.1.6
Supervisor 2024.02.0
Operating System 11.5
Frontend 20240104.0
Raspberry Pi 4
Home Assistant SkyConnect
HASS.Agent 2022.14.0

Hello. I’m almost a year into using HA, but I’ve been having boot issues for a couple of months where if I restart HA, it fails and I am only able to login using SSH.

It usually takes a power-off/on of the Pi4. Sometimes multiple power-off/on before I’m able to login.

After upgrading to either 2024.2.1 or 2024.2.2, when I restart HA I never get a login prompt. Power-off/on of the Pi4 doesn’t work on these releases. I ended up restoring back to 2024.1.6

I have tried disabling the custom add-ons, (except Advanced SSH & Web Terminal) by disabling the option to “Start on boot”, but after HA restarts, it still fails.
Google Assistant SDK
HA Scheduler
Home Assistant Google Drive Backup
Mosquitto broker
Music Assistant BETA
Samba share
Studio Code Server
Tuya Local devices

I tried restoring my installation from my SSD drive back to the SD card and also onto my other Pi4, but get the same results.

I’m at a loss as to what is causing this. I’ve googled this for several weeks with no usable fixes. If anyone has experienced this or can point me in the right direction for a fix, I would be most grateful!!!

Please let me know any additional information needed to correct this problem.


UPDATE: The problem is fixed. I disabled all of the ADD-ONs and HACS. Updated the core 2024.2.2 in safe mode. HA rebooted multiple times without issue. I then re-enabled the HACS, and then the ADD-Ons one-by-one. As soon as I enabled the ADT integration, HA would fail at boot. I restored back to the 2024.2.2 backup that I took after the upgrade and removed the ADT integration.