Home Assistant Community

Cannot open Node Red

#1

I have installed Node-Red, Flow-based programming for the Internet of Things. 2.0.2, add on. But when I click on OPEN WEB UI and it directs me to: https://192.168.10.150:1880/ I get this message:

This site can’t be reached

192.168.10.150 refused to connect.

Try:

ERR_CONNECTION_REFUSED
Check your Internet connection

Check any cables and reboot any routers, modems or other network devices you may be using.

Allow Chrome to access the network in your firewall or antivirus settings.

If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.

If you use a proxy server…

Check your proxy settings or contact your network administrator to make sure that the proxy server is working. If you don’t believe you should be using a proxy server: Go to the Chrome menu > Settings > + Show advanced settings > Change proxy settings… > LAN Settings and deselect “Use a proxy server for your LAN”.

I do not know what is wrong. Anyone who does? Anyone who knows that to try next? I have tried to uninstall it and reinstall it but it won’t work. Is it something with the ports? Should I change ports for the Node Red? If so how do I change ports?

#2

Is node-red running?

#3

I have no idea. How do I get to know that?

#4

What does the log at tye bottom of the addon page say?

#5

Log
[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

Hass.io Add-on: Node-RED
Flow-based programming for the Internet of Things

Add-on version: 2.0.2
You are running the latest version of this add-on.
System: HassOS 2.11 (armv7 / raspberrypi3)
Home Assistant version: 0.89.2
Supervisor version: 150

Please, share the above information when looking for help
or support in e.g, GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[23:04:40] FATAL:
[23:04:40] FATAL: Configuration of this add-on is incomplete.
[23:04:40] FATAL:
[23:04:40] FATAL: Please be sure to set the “credential_secret” option.
[23:04:40] FATAL:
[23:04:40] FATAL: The credential secret is an encryption token, much like
[23:04:40] FATAL: a password, that is used by Node-RED for encrypting
[23:04:40] FATAL: credentials you put into Node-RED.
[23:04:40] FATAL:
[23:04:40] FATAL: Just like a password, a credential secret can be
[23:04:40] FATAL: anything you like. Just be sure to store it somewhere
[23:04:40] FATAL: safe for later, e.g., in case of a recovery.
[23:04:40] FATAL:
[cont-init.d] 10-requirements.sh: exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] 99-message.sh: executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

#6

So the answer is there, complete your configuration.

#7

Not sure how much clearer it can be

#8

Hi! I have still problem but know with logging in with Node Red. I cannot login with my username and password. It does just say Login failed. This is my configuration:

{
“credential_secret”: “MY-SECURE-PASSWORD”,
“dark_mode”: false,
“http_node”: {
“username”: “admin”,
“password”: “MY-SECURE-PASSWORD”
},
“http_static”: {
“username”: “admin”,
“password”: “MY-SECURE-PASSWORD”
},
“port”: 1880,
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: true,
“system_packages”: [
“ffmpeg”
],
“npm_packages”: [
“node-red-admin”
],
“init_commands”: [
“echo ‘This is my text’”,
“echo ‘And this is too’”
]
}

This is the log:
[…]
Welcome to Node-RED

24 Mar 00:16:54 - [info] Node-RED version: v0.20.3
24 Mar 00:16:54 - [info] Node.js version: v10.14.2
24 Mar 00:16:54 - [info] Linux 4.14.98-v7 arm LE
24 Mar 00:16:55 - [info] Loading palette nodes
24 Mar 00:17:01 - [info] Settings file : /etc/node-red/config.js
24 Mar 00:17:01 - [info] Context store : ‘default’ [module=memory]
24 Mar 00:17:01 - [info] User directory : /config/node-red/
24 Mar 00:17:01 - [warn] Projects disabled : editorTheme.projects.enabled=false
24 Mar 00:17:01 - [info] Flows file : /config/node-red/flows.json
24 Mar 00:17:01 - [info] Starting flows
24 Mar 00:17:01 - [info] Started flows
24 Mar 00:17:01 - [info] Server now running at http://127.0.0.1:1880/
24 Mar 00:17:06 - [info] [server:Home Assistant] WebSocket Connected to http://hassio/homeassistant

#9

Hey! Did someone reply to you at all?

I’m having the EXACT same issue and I’m curious because I see people responding to you when you posted your log, but don’t see any responses once you posted your config which clearly shows you’ve crossed your i’s and dotted the t’s.

Sorry I’m new here so am not sure if I’m reading the community forum correctly.

Config:

{
“credential_secret”: “xxxxxxxxxxx”,
“dark_mode”: true,
“http_node”: {
“username”: “xxxxxxxxxxx”,
“password”: “xxxxxxxxxxx”
},
“http_static”: {
“username”: “xxxxxxxxx”,
“password”: “xxxxxxxxxxx”
},
“port”: 1880,
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: true,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}

Log:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

Hass.io Add-on: Node-RED
Flow-based programming for the Internet of Things

Add-on version: 2.0.2
You are running the latest version of this add-on.
System: HassOS 2.10 (armv7 / raspberrypi3)
Home Assistant version: 0.90.0
Supervisor version: 150

Please, share the above information when looking for help
or support in e.g, GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[19:44:03] FATAL:
[19:44:03] FATAL: Configuration of this add-on is incomplete.
[19:44:03] FATAL:
[19:44:03] FATAL: Please be sure to set the “credential_secret” option.
[19:44:03] FATAL:
[19:44:03] FATAL: The credential secret is an encryption token, much like
[19:44:03] FATAL: a password, that is used by Node-RED for encrypting
[19:44:03] FATAL: credentials you put into Node-RED.
[19:44:04] FATAL:
[19:44:04] FATAL: Just like a password, a credential secret can be
[19:44:04] FATAL: anything you like. Just be sure to store it somewhere
[19:44:04] FATAL: safe for later, e.g., in case of a recovery.
[19:44:04] FATAL:
[cont-init.d] 10-requirements.sh: exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] 99-message.sh: executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

#10

His configuration is complete which is why he posted on here for help. Were you able to help him at all?

I’m having the same issue.

#11

No it wasn’t until he was told to read the error message.

#12

Ok, well what do you think is causing an error for me? I’ve posted the log and the config/

EDIT: Actually, I just figured out what was wrong. I needed to restart the pi, not just restart the NodeRED add-on.

The instructions to get these things going are ridiculously vague. The readme on github says " Note : _Remember to restart the add-on when the configuration is changed." which is misleading especially for us no0bs.

Sorry for the trouble.

#13

I don’t think you need to restart the whole machine, but if you think there is an error in the docs, submit a PR.

#14

I recommend removing node-red along with the node modules and reinstall

1 Like
#15

I was unable to access nod red after the 3.0.1 update that included ingress security. I delete my old config settings and added in the new settings and I when I hit save I got loads of errors in red.

I played with my config settings and still no luck. As soon as I uninstalled and reinstalled Node Red the config saved. I restarted Node Red only and I am back up and running. None of my projects got deleted when I did the uninstall/reinstall they were all as they were.

Note if you are worried about your projects and want to back them up but can’t access node red, go to your snapshots and restore an earlier version of Node Red export your projects and then go back and do the uninstall/reinstall.