Cannot present data from P1 Iungo energy controller

Hello, I would like to ask for your help. I recently started Home assistant as a layman, enthusiastic about the Energy Dashboard. I have a P1 connection with Iungo’s energy controller. I managed to export the data from Iungo through the MQTT broker. In the MQTT explorer all data from Iungo is presented. However, I can’t get the next step right, setting up the configuration.yaml. I do not get the data presented from the sensors via the MQTT broker. Who can help me with this? Does anyone have an example configuration.yaml with data from the Iungo energy monitor available? Perhaps also with the first step towards the energy dashboard of Home assistant? Thanks in advance!

Show us a screenshot of the data in MQTT Explorer.


HelloTroon,
Thanks foor the replay, attached the screenshot.

This picture is better.

do check this thread: Connect third party sender (Iungo) to Hassio - Mosquitto

its all a matter of getting the correct mqtt sensor setup in HA.
But, aas I see your screenshot, there’s is not a lot to see, none of the switches appears to have a state, or any power reading?
that is not how it should be, maybe you need to deselect the topic selector in Iungo, to have it publish all data it has available

eg the dsmr4 connection should provide this:

can you confirm to have that too?
if yes, then it is only a matter of getting the correct topic into the mqtt sensor

DSMR

##########################################################################################
# Slimme Meter DSMR4
##########################################################################################

mqtt:

  sensor:
    - unique_id: nettot_verbruik
      state_topic: '70:B3:D5:6F:31:F2/energy-dsmr4/538d72d9/usage'
      name: Netto verbruik

I see you also have the 630 Modbus:

##########################################################################################
# Modbus 630 Inductieplaat
##########################################################################################

    - unique_id: inductieplaat_actueel
      state_topic: '70:B3:D5:6F:31:F2/energymeter-sdm630-modbus/64904b93/usage'
      name: Inductieplaat actueel

DO note that Iungo refuses to correct the issue they have since day 1: they mix up energy/usage with should be the kWh, and power which should be in W…
Have been in contact with their dev team for years on that, but gave up.

some extra settings are required in the sensor config, like

        unit_of_measurement: W
        value_template: >
          {{value|round(2,default=none)}}
        device_class: power
        state_class: measurement
        qos: 1

for the power sensors, and

        unit_of_measurement: kWh
        value_template: >
          {{value|round(2,default=none)}}
        device_class: energy
        state_class: total_increasing
        qos: 1

for the energy sensors. These can easily be copy/pasted using yaml anchors, but that is for later.

Hello Marius,

I had seen that thread, thanks for that, it helped me set up the broker.
All parts are published from Iungo, which works. I just didn’t expand the fields on the screenshot.
Thanks for the examples of the configuration.yaml, I can now present the data as an entity.
I was also able to take a step to the Energy Dashboard regarding T1 and T2 import and export, I still have to find out about the solar panels, charging station and gas, do you have any tips?
For calculating the daily values.
Thanks again!

sorry I missed this…

calculating daily values is done by subtracting current at midnight from day_start values the Iungo creates. You can automate the process.

Even better probably is by adding the sensor values to the Utility integration, and it will do all the math for your and create daily, monthly and yearly for you

Read this topic with great interest. Helped me to connect my Iungo to HA through MQTT. However I can’t figure out what kind of sensors must be configured in the YAML file. Just a few examples of some energy sensors that can be used as variables for the Utilitydashboard would be wonderfull.