Cannot Remove Helper

I have a Group helper which I cannot edit or delete. If I look in the list of helpers I see the name “Bonus Room Lights” but the Icon next to it is a red circle with a “!” in it. If I open the Dialog box for this Helper ther is no delete button. If I click submit, it says it is successful, but there is no entity shown in the Helper list for this Helper. I also looked in the entity list and it does not appear to be there. Any idea how to get rid of this?


Have you tried powering your HA instance off and on (not just restarting it)?

Tried this and it did not help. Everything is still the same…

same for me

I have the same problem

I can’t delete or edit helpers. I’ve read all sorts of comments in the community but none of them apply. I’ve got an input_boolean and a toggle. I’ve looked everywhere from the Helpers dashboard and through the Entities dashboard but nowhere is there a way to delete or edit the helper or the entity. What gives?

update: 2023-12-16
Using Windows Edge the Delete link on the Helper’s properties page was greyed out, but, strangely enough it’s working now. I came here to report that the Delete link was active when using the iOS App on my iPhone but now I find it working in Windows as well. I have no idea. I must be going nuts.

I’ve now got the same issue, did you ever find a solution?

Same problem.
The delete button is not visible from the web frontend.
If I use the Android application instead, the delete button is visible and I can use it.
I hope this helps while waiting for a permanent solution.

Delete button still not available for me in the android app. Thanks for the thought…

Has anyone come up with a way around this problem, please?

I asked a question in another post and was advised to set up a “Helper”. I did this and now cannot get rid of it (it doesn’t work and just has a red exclamation mark to the left of it).

I want to delete it and get back to a clean slate so I can try and understand what went wrong, but it seems that there’s no way to do this. At least I’m reassured that others have had the same problem, although I’d really like to get things back working again, as HA has been pretty amazing for the past year or two and we’re now very much used to relying on it!

In March 2024 I have still same problem. It looks like bug, but nobody solving that.
I can not delete or edit helpers. I tried restart HA, tried clear browser cache, try two web browsers (Firefox and Edge). Try to delete from Entities and from Helpers. It is impossible to delete or change helpers.

In Helpers I had a similar issue with the HACS calendar. Clicked on the helper to delete, clicked the gear icon then the bottom of that window there’s a Delete. Not sure if that’s the one missing for some but took me a while to see it.
Using HA app on iOS.

The “Delete” option is there indeed (unless you defined a helper in yaml). Just click on Settings > Helpers > (click on helper) > cog wheel in top right > Delete (bottom left of popup)

Actually, the ‘Delete’ option is grayed out. Strangely, these are all helpers I used to have, but deleted some time ago.

In Settings > Helpers, in the right-hand column, there is a pencil icon with a slash through it next to each un-deletable helper. templates.yaml doesn’t contain it. A text search in the Config folder gets no hits, either.

Check if you have a groups.yaml somewhere in your config. If not, then you might still have the entries for those helpers in the hidden) storage folder which you’d have to remove manually.

Be very careful if you’re poking around in there and make sure you have plenty of backups of that folder before you touch anything. One misplaced comma and your system won’t load, so use an online json validator before applying changes.

A safer way which might work is check Settings > System > Repairs for anything related to those helpers. Can’t remember offhand, but if they show up it should let you delete them from there.