Cannot remove homekit bridge

Hey all,

Has anyone been successful in removing the home kit bridge from haOS? I’ve been pulling my hair removing the services, only to readd the integration and it pairs the old home kit… Normal operation is when it doesn’t find a parable device, it asks for one, I put in my numbers and the device is paired.

In this instance it continues to pair the same device over and over again.

My system resides on a Proxmox instance with Homebridge on its VM. I ran into some issues and had to redo the Homebridge

I’ve heard some of the only ways are utilizing Dev tools, clicking services, and unpairing a bridge, but I’m unable to find the correct target; it doesn’t exist, but a number of services are listed in this screenshot

Trying to avoid the final Hail Mary of redoing the entire os!

use the Integrations tab - you are on the Devices tab.

Thanks for replying

Even through integrations, there’s no way to remove the integration, I can remove each entry manually and the homekit bridge will remove from the general integrations tab but trying to readd it adds all the removed integrations…

I think you are running a version prior to 2023.7 (where the integrations interface changed) so I cannot show you a screenshot, but the remove option is on the page prior to the one you are showing.

Press the back arrow (top of screen, to the left of "HomeKit bridge). This should take you to a list of all your integrations and the remove option is there (I think in a menu you see when you press the 3 dots.

edit: ignore my first paragraph. …I’ll get back to you.

edit: OK, Try deleting the bridge itself (the bottom 2 in your snapshot). If that doesn’t remove everything then, yes, it appears you need to remove each entry individually.


Even though I’m able to remove each entry, when adding with a new homebridge, it adds the old one.image|643x500

I’m not sure where to go to allow me to enter in new homebridge. It won’t even discover a new homebridge.

Unless anyone has any further ideas, might be looking at a rebuild.


Any results for this?
I have this same problem and figure out how to get rid of the homekit bridge.

On another thread (sorry, can’t remember which) I read about a similar problem with re-adding the AppleTV integration and the solution (which worked for me) was to stop HA and remove entries for AppleTV (or homebridge in your case) from the following file:

file: core.config.entries
location: \.config\.storage

  • .storage is a hidden directory
  • Do this at your own risk - “here be dragons”
  • Backup HA first!
  • HA cannot be running when you do this
  • There may be more than one entry as I think one is created for each attempt.

Here is an example of my App’eTV entry in the file:

        "entry_id": "1ec16323f62a47966dbaf9af65966d14",
        "version": 1,
        "domain": "apple_tv",
        "title": "Mac mini (Music/iTunes)",
        "data": {
          "address": ""
        "options": {},
        "pref_disable_new_entities": false,
        "pref_disable_polling": false,
        "source": "ignore",
        "unique_id": "F4B3BD80F713",
        "disabled_by": null

Good luck!

I was able to delete Homekit Bridge by deleting every entity in entities.

I delete from with the integration and yes it went away