Cannot remove z-wave device

Hi all,

I recently tried adding a Danfoss thermostat to my HA instance. For some reason, I didn’t notice that the device was added successfully so during the inclusion process or immediately after I seem to have tried including the device once more.

As a result, I now have 2 entries for the same device: one is sleeping and working accordingly, and the other one is Initializing (CacheLoad) for over a week now.

Is there any way to remove the duplicate device (the one in Initializing state)? I though HA would mark it as dead, but it’s been a week now and nothing happened.

Many thanks.

Have you tried using the Configuration > Z-Wave > Remove failed node under node management?

Otherwise, you might have to modify the entity_registry.yaml file manually with a text editor.

That will only work if the device is marked is_failed: true - but at that point it will work.

Removing it from zwcfg*.xml might remove it from HA - but only if it’s not actually included on the controller. If it isn’t, then it’ll return automatically since the controller believes it should be there.

Hi guys,

I tried both options, removing the device from entity_registry and from zwcfg*. Unfortunately, none worked - the device is still there.

I wonder if I remove the clone device that’s working from the zwave network would remove both nodes given that they’re the same.

That’s because the controller still thinks it’s included.

It won’t, because they’re not the same as far as the controller is concerned.

You’ve got two options - one is to hide it until it’s marked as failed, the other is to remove all the Z-Wave devices from your controller, then factory reset the controller.

Thanks Tinkerer. Unfortunately the option to factory reset the controller, although good, would be a nightmare as I have over 60 devices included in the network. So I guess what remains is to hide it for now and check in a couple of days / weeks if it was marked as dead.

This worked for me…

  1. Remove the device from it’s power source (unplug it, unscrew it, whatever)
  2. Find the node_id of the device.
  3. Execute Call Service zwave.remove_failed_node using service data: {“node_id”: “x”} (Replacing x with the node_id.
  4. Restart HA.

If this doesn’t work. Try again in about 8 hours once the device goes into a dead state.

It has to be marked as is_failed: true for that to work, simply being in Dead state isn’t enough.