Cannot reset ikea IKEA E1524/E1810 Round with 5 buttons

I have two ikea round 5 button remotes IKEA E1524/E1810 control via MQTT | Zigbee2MQTT which I tried to pair with first a couple of lights but could only get it to work with one , then tried to do a group but this too failed. At each attempt I have removed these controls from zigbee2mqtt via Force remove and then read a verdict again by pressing the par button. But somehow the first light I read in seems to remain in some memory because when I press the center button it turns on and off immediately after I read it in again. Is there any other way to reset the remote? Reload firmware?

This is how the status of a working one looks like

    "battery": 20,
    "last_seen": "2024-05-31T22:51:19+02:00",
    "link quality": 153,
    "update": {
        "installed_version": 604241925,
        "latest_version": 604241925,
        "state": "idle"

and this is how it looks on the one with problem .`

    "battery": 20,
    "last_seen": "2024-05-31T23:01:43+02:00",
    "link quality": 153,
    "action": "",
    "update": {
        "installed_version": -1,
version": -1,
        "state": null
    "update_available": null

To me it seems you are doing it wrong. Why do you try to pair the remote directly with lights? It defies idea of HA. Instead get it included in HA and use it as trigger in automations to control your lights. Or am I getting it wrong?
Pairing remote with HA (not sure how it is done in Zigbee2MQTT, I use Deconz) should remove any other pairings to lights. Same with lights (at least Ikea Tradfri), pairing these with HA removes pairing with controller.

I whant it to HA but when i bind it to bulbs directly it works faster and when Ha is down or rebout. The problem is that it seems like i cant reset it and therefore not use it in automation eather.

What firmware is it on ?

< 2.3.014: binding is not supported, OTA update your device to get binding functionality
2.3.014 - 2.3.074: suppports binding to groups only. It can only be bound to 1 group at a time. By default this remote is bound to the default bind group which you first have to unbind it from. This can be done by sending to zigbee2mqtt/bridge/request/device/unbind payload {“from”: “DEVICE_FRIENDLY_NAME”, “to”: “default_bind_group”}. Wake up the device right before sending the commands by pressing a button on it.
2.3.075 - 2.3.080 : supports binding to devices only
24.4.5: supports binding to device or groups

What you mean it works faster when paired directly vs. via HA automation? I use it exclusively via HA and responce is instant (below 0.5 sec or less - as I use in most cases spft transisions it is hard to measure).

How often your HA is down? My system has 98.9% availability (as measured by UptimeKuma) and this is only because of myself fiddling with system (changing configuration to the extend that it requires reboot or some integrations updates that require reboot - but it always within controllable by me time). So if it does not work for you as expected, I’d rather assume there is something wrong with your HA setup, than this controller (unless like Francis pointed you use some otdated FW).