Cannot see files in config after restoring backup

Hi all,
I hope you can help me out.

I had to restore a backup but after doing that I can no longer see the content of the config folder.

What do I have to do to see it again. All my configuration files seem to be gone but everything is working so they must be somewhere.

Thanks for your help.

Merc

How are you attempting to access the config folder?

What sort of installation do you have?

Hi tom_I,
I am running it on a pi with HA OS.

I did an incremental backup restore (and possibly that was a mistake) and wanted to check the configuration. yaml through file editor as usual. But the whole configuration folder is gone in file editor.
Through Samba I cannot get into the config folder either.

Everything is running but e. g. in the Esp setting my adapters are not showing up… but the devices are still working…

All very strange to me.

Appreciate any hint.
Thanks,
Merc

Whatever I tried I could not find it anymore.
So I went back to a FULL backup from about 3 weeks ago and installed this.

Everything is working again but I really do not understand what had happened.

Is this expected behaviour, i.e. does a partial backup installation lead to config files missing?

In any case, I have learned something again and thank your for the help.

Merc

Same thing happened to me.

I had the exact same behavior. Did a partial restore to the Home Assistant part of the backup, and the config folder is now completely empty, including subdirectories like .storage.

I tried that after carefully watching some videos about backup and restore, to better understand the process, but that came as a big surprise. Looks like an undocumented feature to me :frowning:

I also tried to manually create a file under the config folder, but I get an error “no such file”.

I would also like to understand what is the solution for this…

Mystery solved - just disable the Protection Mode in the Terminal Addon and then restart it.

However, it is still missing from the file editor…