Cannot seem to connect to the internet with HA after switching routers

I’ve just got a UDM Pro and everything seems to be running smoothly apart from HA. For whatever reason, it seems to have completely stopped getting access to anything on the internet.

I first noticed when trying to set up duckdns and started seeing “curl returned with 6” errors, I tried pinging websites with no luck (bad port spec) and started noticing that a lot of internet dependant integrations looked like this:

Screenshot 2022-06-04 at 02.06.09

So far literally the only thing that has changed is me plugging into the new switch to the UDM. Any ideas?

Edit to add: I run the OS on a RPI4 and use a static IP

I mean I guess start with the obvious:

  1. Is the new network using the same subnet as the previous network? The static IP HA is trying to use still makes sense right?
  2. What about the gateway and DNS server you configured, those still make sense in the new network?
  3. Does everything else have internet access?

And then the less obvious (although unlikely if you did nothing other then plug both things in):

  1. Is the port set to the correct network/vlan?
  2. Any firewall rules blocking internet access?

Yes to all 3, and no, there are no firewall rules blocking internet access. I’m pretty stumped as to what else to look for as all of this is relatively new to me.

I used to use Tailscale which I’ve also disabled and now I can’t seem to access my local instance on my phone even though I’m on the same network. Rather interesting. Edit: I’ve resolved this with a switch to “internal link” for now.

1 Like

Right. Woke up this morning having done nothing else and somehow it seems to have automatically resolved itself. No idea what this was about. Has anyone else had this experience?

sounds like dhcp timed out and requested an update ?

1 Like