Cannot start addon: no space left on device

From time to time my Node-Red addon stops working with the following error:
Can’t start addon_a0d7b954_nodered: 500 Server Error for http+docker://localhost/v1.41/containers/a7b66ba697a19f694afca72eb799f6a12fd987b85b6d58a618995eb1a8cff9c6/start: Internal Server Error (“failed to open stdout fifo: error creating fifo /var/run/docker/containerd/a7b66ba697a19f694afca72eb799f6a12fd987b85b6d58a618995eb1a8cff9c6/init-stdout: no space left on device”)

I run Home Assistant on a Raspberry Pi 4 with an external SSD. According to Settings → Storage only 12% space is used, with 184,5 GB free. So I can’t understand why it say disk is full.
If I restart HA problem is solved for a short time, then it comes back.

Anyone has a solution to this issue?

1 Like

I started having the same issue a day or two ago, node red won’t start up, and neither will any other add-on that isn’t already running. My ODROID’s storage is only at 9.5% with 97GB free.

1 Like

Same here on Intel NUC. Still 270GB free space left. Already tried docker prune, no effect.

Edit: As soon as I stop some addons, I’m able to start others.

I only have problems with the Node-RED addons, all other works as the should. So at the moment I need to restart Home Assistant from time time. So I hope some clever head can point me and others in the right direction so this can be solved.
Thanks :slight_smile: