Cannot start DHCP Server with default or suggested configuration

I’m attempting to configure my first DHCP server, and found the following message when attempting to save the ‘default’, or suggested configuration from ‘home-assistant, addons/dhcp_server’:

not a valid value for dictionary value @ data[‘options’]. Got {‘domain’: ‘’, ‘dns’: [‘’, ‘’], ‘networks’: [{‘subnet’: ‘’, ‘netmask’: ‘’, ‘range_start’: ‘’, ‘range_end’: ‘’, ‘broadcast’: ‘’, ‘gateway’: ‘’, ‘interface’: ‘eth0’}], ‘hosts’: []}
I’m not sure why the error isn’t more specific, I’ve tried removing one line at at time, but it keeps showing the same error.

I’m using the following configuration, and have entered an arbitrary domain name. I imagine the setting is set here, and can be anything, not having to match an existing one?

“domain”: “”,
“dns”: [“”, “”],
“networks”: [
“subnet”: “”,
“netmask”: “”,
“range_start”: “”,
“range_end”: “”,
“broadcast”: “”,
“gateway”: “”,
“interface”: “eth0”
“hosts”: []

" is the correct form, not those curly things you have there.

I should have checked, but it seems it was ‘translated’ as curly speech marks instead of standard.
" is how it’s shown in the actual configuration. It seems anything pasted converts the text, please see the preformatted text below.

  "domain": "",
  "dns": ["", ""],
  "networks": [
      "subnet": "",
      "netmask": "",
      "range_start": "",
      "range_end": "",
      "broadcast": "",
      "gateway": "",
      "interface": "eth0"
  "hosts": []

That looks better. It passes json lint validation here

I am not sure about naming your domain though. That looks wrong.

Also maybe take the hosts bit out altogether, perhaps the fact that it is empty is annoying the validator.

I just installed hassio in a VM to test. I have the same result without changing anything in the config. I suggest you post an issue on github.

1 Like