Cannot start Zigbee2MQTT

Hi Community.

I am a HA newby and trying to get my installation to work.

Raspi 4
HA OS

  • Core 2023.11.3
  • Supervisor 2023.11.6
  • Operating System 11.1
  • Frontend 20231030.2

I installed Zigbee2MQTT and it does not start. I keep on getting the message that the addon cannot start.

Screenshot 2023-11-29 204919

I tried de- and re-installing - did not change anything.
Anyone any ideas?

Thanks for your help all!

since I can only share one screenshot per post - here is the second error message I get:

Anything in the Zigbee2MQTT logs?

no, nothing

logs

correction - could that mean anything? (supervisor logs)

23-11-29 20:50:23 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:default [Connect call failed (‘172.30.33.0’, 8099)]
23-11-29 20:50:55 WARNING (MainThread) [supervisor.addons.addon] Watchdog found addon Zigbee2MQTT is failed, restarting…
23-11-29 20:50:55 INFO (SyncWorker_4) [supervisor.docker.manager] Cleaning addon_45df7312_zigbee2mqtt application
23-11-29 20:51:23 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.33.2-1
23-11-29 20:51:42 WARNING (MainThread) [supervisor.addons.addon] Watchdog found addon Zigbee2MQTT is failed, restarting…
23-11-29 20:51:42 INFO (SyncWorker_3) [supervisor.docker.manager] Cleaning addon_45df7312_zigbee2mqtt application
23-11-29 20:52:19 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.33.2-1
23-11-29 20:52:51 WARNING (MainThread) [supervisor.addons.addon] Watchdog found addon Zigbee2MQTT is failed, restarting…
23-11-29 20:52:51 INFO (SyncWorker_3) [supervisor.docker.manager] Cleaning addon_45df7312_zigbee2mqtt application
23-11-29 20:53:18 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.33.2-1
23-11-29 20:53:46 WARNING (MainThread) [supervisor.addons.addon] Watchdog found addon Zigbee2MQTT is failed, restarting…
23-11-29 20:53:46 INFO (SyncWorker_1) [supervisor.docker.manager] Cleaning addon_45df7312_zigbee2mqtt application
23-11-29 20:54:09 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.33.2-1
23-11-29 20:54:38 WARNING (MainThread) [supervisor.addons.addon] Watchdog found addon Zigbee2MQTT is failed, restarting…
23-11-29 20:54:38 INFO (SyncWorker_1) [supervisor.docker.manager] Cleaning addon_45df7312_zigbee2mqtt application
23-11-29 20:55:12 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.33.2-1

Go here Open your Home Assistant instance and show the dashboard of an add-on.

Then click logs. Then copy and paste what you see.

It sounds like you have not configured zigbee2mqtt.

1 Like

As a data point, I did a new install last night and started the AddOn w/o any config and in my case it at least came up just enough to create the zigbee2mqtt directory in HA config along with a default set of configs in its configuration.yaml file, and it did send some output to its logs and yeah it eventually failed (due to no Zigbee Stick config) as expected but it least it output some log messages.

But here the supervisor can’t even start the AddOn as if it the Docker image is corrupted, or wrong architecture. It says its using an aarch64 which I think is correct for Raspi4 (but not entirely positive).

However I’m scratching my head concerning the first line in the log above where it says the supervisor can’t connect to the host using port 8099 which is what Zigbee2mqtt UI uses. I’m wondering if there is another AddOn using port 8099?

[EDIT] I take that back. Its probably not a port 8099 problem as I have also installed two Add-On instances of zigbee2mqtt on haos and both used port 8099 (so I now doubt this is the problem).

1 Like

Lets just see what happens when he posts the logs from the actual addon :slight_smile:

2 Likes

Stupid question: u have a zigbee usb stick installed and configured, right?

1 Like

Hi all,

first of all, thanks for your help!

Some more details:

  • yes, I have the SONOFF Zigbee 3.0 USB Dongle Plus installed (works well with some temp & humidity sensors)
  • I have Mosquitto broker add-on installed (seems to be running, at least I have the “green” light in the upper right corner)
  • I thought I have Zigbee2MQTT configured (but not sure, it is correct - I followed the instructions from here GitHub - zigbee2mqtt/hassio-zigbee2mqtt: Official Zigbee2MQTT Home Assistant add-on)

here is my configuration

logs are empty

Where is the configuration for the MQTT server?

Something like:

server: mqtt://ip-of-mqtt-server:1883

how does you configuration.yaml under the zigbee2mqtt folder (not the config folder for HA) look like?

1 Like

Just an FYI, if one is using HAOS and using the MQTT Broker AddOn, the user need not enter any MQTT settings… z2m will somehow be auto-configured with the internal url of the MQTT Broker AddOn along with a username/passwd to the MQTT Broker.

2 Likes

Check in your configuration.yaml as above, you will find it there :slight_smile:

1 Like

If it is working with sensors then you must have zha configured. You can’t use zha and z2m at the same time.

ok, yes I have ZHA installed - better said, it came with the package.

I did not know that I cannot use this in parallel.
Thanks for pointing this out!

Then I can spend the evening google’ing ZHA vs. Z2M.

Thanks ALL!

1 Like