Cannot turn_off Tado

Hello community,
Im trying a simple automation with Tado climate, like:

- id: bedroom_off
    platform: numeric_state
    entity_id: sensor.bedroom_temperature
    above: 22
  - service: climate.turn_off
    entity_id: climate.bedroom

But I’m receiving the following error:

2018-10-20 07:10:36 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/", line 224, in _handle_service_platform_call
    await getattr(entity, func)(**data)
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/climate/", line 611, in turn_off
    raise NotImplementedError()

How Can I turn off the Tado climate?

Thank you

Use climate.set_operation_mode and set it to “Off”…

Thank you it works perfect!!! :+1:

Maybe I have to modify the conditions, it seems it doesn’t work :thinking:

  - condition: state 
    entity_id: climate.bedroom
    state: 'on' 


  - condition: state 
    entity_id: climate.bedroom
    state: 'off'

The state of a Tado climate device reflects its operation mode. What are you trying to to do? Switch the device off when it is not already off? That would be

- condition: template
  value_template: "{{ states.climate.bedroom.state != 'Off' }}"

Thank you, it works perfect! :+1:
And yes, I have to switch the device off when it is not already off because I have also pushbullet notification, so, in this way, HA doesn’t send useless notifications.