Cannot update from 0.88.2 to 0.89.2 -> 500 Server Error: Internal Server

Hi all

I am having trouble upgrading from 0.88.2 to 0.89.2 - I am getting the following in the logs:

19-03-17 13:27:02 INFO (SyncWorker_11) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.89.2.
19-03-17 13:27:04 ERROR (SyncWorker_11) [hassio.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:0.89.2 -> 500 Server Error: Internal Server Error (“readlink /mnt/data/docker/overlay2/l: invalid argument”).

I tried rebooting several times, getting the same error 500 when trying to upgrade any add-ons like DuckDNS, Samba etc.

Anyone seen this or found a solution?


hi, all first of all thank you for joined me into this forum.
i need an help, i’m unable to update hassio from 0,92 to 0.93 (hassio installed on raspberry).

particularly i received the following error:

error (syncworker_13) [hassio.docker.interface] can’t install homeassistant/raspberrypi3-homeassistant:0.93.1 -> 500 server error: internal server error (“readlink /mnt/data/docker/overlay2/l: invalid argument”).19-05-18 13:11:41

thank you on advance



Hi Antonio

I could not resolve the issue, and I ended up backing up all my configs and snapshots, re-imaged to a new SD card and re-configured it from scratch. I did not restore any snapshots, and too this opportunity to tidy things up a bit and much better now. The root cause of the original issue is unknown, I just used a new SD card.

thank you very much!! i will do it. but why you don’t restore the snapshot? i will try and i will give you notice. thanks for your help

I found that re-configuring it from scratch will make you tidy things up a bit - mine was in a terrible mess since I have been upgrading the same install from version 60+ and I didn’t want to bring in the sloppy practices I have been working since the beginning - it took less than an hour to reconfig and I am really happy with mine now.