Cannot update HAOS and "Could not load the Supervisor panel!"

My HAOS is on a rPI 3, and is currently on 2023.2.5
I want to update, but on the update page it says no updates available.
So I go to Addons to add SSH so I can update that way, and I get the message “Could not load the Supervisor panel!”
However, if I go to the observer at homeassistant.local:4357 it says the supervisor is connected

Please advise on what I need to do. Thanks

Connect a keyboard and a monitor to your PI, and update through the console ( If you can ), And BTW, lots of people have posted Topic with exactly same " Issue/question" , so a simple search in the Forum-Search would have “helped” you

My small 2cents, hope you figure it out

Sorry, I did search, but didn’t see any issues the same as mine

The main purpose with a search, in a forum like this, is Not to find an exactly match !, But to use the Right Key-Words in your search, and then go through the results, click a few which seems “familiar”

1 Like

BTW, all working now. I just did a hard reboot.
My guess is that the supervisor went down at some point, even though the observer said it was running.
All updated OK

1 Like

I never asked you, but in the update page, if you click the 3 Dots, it will/should reveal “Skipped Updates” , and sometimes when i.e an update goes wrong(at certain state) the update will end in Skipped, or just don’t show up after a “Restart”, But good to see that you tried a hard-reboot, and this worked , i periodically do this whether i just experience “minor” issues, just in case, before going into the “darkness” of deep troubleshooting, and/or Debug :slight_smile: